No native resolution option in display settings

I have been using Ubuntu Budgie for about 2 weeks now and enjoy it very much, but I have encountered a slightly annoying problem. Recently, I realized that the resolution on my laptop monitor is set to 1920x1080, when my native resolution is 1600x900, with no option for native resolution in the dropdown list. The strange thing is that on my second monitor (which has a native resolution of 1920x1080), the 1600x900 entry is listed in the resolution list. I have tried adding a custom resolution using xrandr, but although the resolution appears in the list now, if I select it, the display just goes black (the other one still works) and I have to wait for the system to revert my resolution to be able to use that screen again.

Hi and welcome.

This is a generic issue - any answer for GNOME Shell will apply to Budgie in this area - so you can also ask on and as well to have the more experienced people in this area to advise.

From my limited viewpoint - double check that this isn’t a cable issue - try VGA cable rather than display port/HDMI.

Also double check if you are using nvidia graphics that you have the recommended nvidia graphics driver installed (Menu - Hardware Drivers)

Thanks for the tip, I will post my issue there aswell and see if I can find a solution.

As for your advice,
The cable isn’t an issue, the display that doesn’t show the resolution is the built-in display of the laptop, but I have also tried booting without the second monitor and the resolution is still not present.
As for you second suggestion, I can’t seem to find the menu :sweat_smile:. The closest thing I’ve found is Additional Drivers which yields “No additional drivers available”.

Thank you for the quick reply and for the suggestions!

BTW - you didn’t mention the UB version - is this 18.04.5 or 20.04.1? If you are using the former I would recommend having a look at a live-session of 20.04.1 via USB to see if the latest graphics stack works better.

I am using version 20.04.1.