Dynamic Workspace not working anymore UB 18.04

If the Dynamic workspace is not working anymore on my computer
Where do I start to try to fix it ?

I can move from Workspace 1 to Workspace 2 with customer keyboard shortcut I created

4.15.0-17-generic #18-Ubuntu SMP Mon Apr 16 22:22:42 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Gnome 3.28.1

What happens if you run from a terminal:

/usr/share/budgie-desktop/visualspace/visualspace next


/usr/share/budgie-desktop/visualspace/visualspace prev

just tried on my 18.04 laptop -same issue, but was solved after a restart. Did you try to restart?

Using your commands, it is working…

I created customer keyboard shortcuts with your commands tks !

Happy that it works, but it should work out of the box. Did the shortcuts “Move to Workspace left” and -“right” exist anyway?

Yes they were and ti was working
I just tried in a VM to press RESET ALL in the keyboard shortcut to see if it was that, that initiated my problem and no… The Reset All ShortCut buttun, who warn we could look all our custom shortcut, does not delete the Custom shortcut we used for workspace,…

So I don’t know what happened but creating new one with the command solved my problem
And By taking a 2nd look, the initial / original shortcuts were there but disabled… So I missed that when posting my questions… What disabled them ? Don’t know…