Firefox title bar is always black after Budgie update (20.04.1)

Not sure if this happened after a Firefox update or after an UB update. I am up to date with my 20.04.1 system but suddenly the top (title) bar is always completely black with Pocillo or Arc (darker). It was not like that. It also behaves differently from other windows such as the File Manager.

The title bar used to be exactly like the File manager and other applications:
Screenshot from 2020-11-02 12-24-09

You cannot even distinguish Firefox from an active window or background window:
Screenshot from 2020-11-02 12-24-23

What could have caused this?

Certainly can’t be a budgie update given that its app specific.

Firefox was last updated by Canonical on the 22 Oct - so if you haven’t updated since then it might be the firefox update itself.

Test also if it isn’t something wrong with an extension you may be using - launch firefox with its ProfileManager option to create a new profile - see if you can reproduce this.

Alternatively temporarily create a new account and login with that.

That was the first thing I did after I couldn’t figure out what caused it: new profile.
It is strange. It happened on my workstation and my laptop pretty much at the same time. Must be a Firefox thing. They probably updated their default themes.

Beware latest Firefox update uses « no title bar » as a default option.

You may change that in settings / customize / bottom left of the page / tick « title bar ».

I obviously noticed that change because I use pixel-saver : I therefore had twice windows buttons…

… think I have a fix for this … needs a thorough bit of testing https://github.com/UbuntuBudgie/budgie-pixel-saver-applet

Well, here the problem is really Firefox.

Before the update, Firefox used to use the title bar. After the update CSD mode became default.
Once you re-enable « title-bar » everything is fine.

The idea of an exclusion list for pixel-saver is nice, though.

[ off-topic ] And such an exclusion list would also be welcome in global-menu + an option to apply global-menu ONLY to maximized windows.

dangerously off-topic … ! I haven’t had a look at the global menu for quite a while but I do think it has an exclusion list - if it doesnt it needs to be requested via the upstream tracker for that applet.

[ off-topic, end ] /org/appmenu/gtk-module/ has got an exclusion list but ; not global-menu applet on its own. See https://gitlab.com/vala-panel-project/vala-panel-appmenu/-/issues/326 and https://gitlab.com/vala-panel-project/vala-panel-appmenu/-/issues/325

I’m not on Budgie right now, hence I can’t check if that changed behavior is specific.
But both my Ubuntu and Manjaro installs still have “Title bar” checked after upgrade to v82.

Well, coincidence maybe ? But I noticed that difference right after FF update to 82.0+build2-0ubuntu0.20.04.1.

Anyway, @zilexa 's FF here has obviously no title-bar, hence no matching color to windows state ( see, the window buttons here are in the menu bar, not in a window title bar. If menu was not shown, window buttons would be next to tabs. )

edit : it seems I can’t disable FF title-bar - I don’t really want to, I was just trying to end with same result as Zilexa.


…maybe because I use pixel-saver + global-menu applets ?

Another strange thing, according to https://www.omgubuntu.co.uk/2019/01/firefox-66-csd-by-default no title-bar is default behavior since v66 of FF ???

I didn’t say his issue was of a different nature, on that I’m absolutely with you. :wink:

I just don’t think this has been forcefully overwritten on existing Firefox installs for everyone when upgrading to v82. On the other hand, it’s very likely it was changed on new installs or new profiles since it became default
And it tends to be confirmed as I didn’t get the same change as zilexa on 2 different distros on v82 (with Gnome and the Unite extension, similar to pixel-saver). I’m always using title bars as I’m no CSD fan. I have tabs below though, through a CSS file.

I would have to try on budgie if there’s some kind of difference

I figured it out.

First of all, note Firefox allows you via right-click context menu (on an empty bar area) to enable menu bar. This is not the same as title bar.
Via right-click context menu > Customize … you can enable title bar. Enable that, and I have what I want:
Screenshot from 2020-11-04 22-25-47

Why did I start this topic?
Well I use vertical tabs, and always had a single line in my firefox profile/chrome/userChrome.css file to hide the default tabs bar. To still be able to close/minimize/maximize my Firefox, I had the Title bar.
(it seems pointless to have just those buttons in a Pixelsaver Panel. And in the rare case I need the Alt menus, I can easily enable them temporarily via context menu).

Then something happened:
For some reason, I created a new profile, forgot to backup my .css file, googled what I had put in there and… put in the wrong code: hiding the contents of the tabs toolbar, instead of the tabs toolbar itself.

Consequence:
This is where the fun starts: I now had exactly the same bar at top that a fresh new profile has: the tabs toolbar with window buttons! I just did not recognize it as such, thought it was a title or menu bar (with hidden menus). In reality, it was an empty (no buttons for new tabs, no tabs) tabs toolbar.

As I was missing the default Budgie menu bar, I thought something was missing.
To fix it, I changed my userChrome.css to remove the tabs toolbar. That’s all!

To get my Window buttons back, I simply enable title bar via context menu > Customize…
As an added benefit, Firefox looks like every window now, with the generic title bar.

Conclusion for others:

  • If you want Firefox top bar to look like any other Window, just enable Title bar. Note that title bar never contains the menus, those are in Menu bar.

  • During my testing, I also tried Pixel Saver. Had some weird behaviour like in the screenshot from @Coeur-Noir, Pixelsaver weirdly added the titlebar to the window during max/minimise. Not THAT weird, the weird par are the window buttons. But that makes sense: by default they are in Tabs bar. If Menu bar is enabled, Firefox moves them up, otherwise it would be very weird to have menus above your window buttons.

Hope this rant is useful for someone :slight_smile:

…if title-bar is disabled in FF, which seems to be its default behavior on most OS.

1 Like