Fractional scaling does not work correctly

As the title says, it does not work well, every time I have tried to scale the screen when I put 125% the size looks the same as if I put 200%.
I have seen another topic that complained that he was left at 200 but when the screen crashes but mine is different, it has never worked for me at 125% so I have decided to do another topic.
This is very annoying because my laptop screen is a bit special and although the resolution is fine, the scaling should be a little bigger to see it better, something that I have tried in Windows and if it works for me and I set it by default.
I wish this could be fixed since sometimes my eyes get tired and I don’t want to switch to another distro or even Windows just for that nonsense.
Hopefully you can do something, thank you.

This is what it looks like at 125%, that’s the whole screen full.

Edit: Even now after trying fractional scaling I get this amdgpu error when shutting down…

Strange because this laptop has a dedicated nvidia gpu but the cpu is amd so I don’t know if it is like trying to use the integrated graphics of the cpu, but I repeat this has been since I have tried fractional scaling, since just today I I have installed the system, everything clean no errors so far and after testing the scaling there is the error, in addition to the error mentioned before that when I put 125% it is set to 200%, this is very annoying.
Apparently everything works normally now but the error keeps coming up. In addition to the error that also appears in the photo that talks about the blocks, but I have always had that in all the computers that I have installed ubuntu budgie, even with the version before the current one and the LTS version, I know that is another problem, but just to comment on it, although it has never given me problems or at least I have not felt that those of…

This is a bug with Canonicals X11 based scaling implementation.

Please report a bug to launchpad


ubuntu-bug libmutter-6-0

After reporting, do look at this thread about how to use xrandr to scale

Perhaps it’s nVidia related?

On a Intel Core i5-8xxx laptop and a Ryzen 4xxxU laptop, 125% scaling does work.

The issues are with:

  1. Lockscreen / screensaver (it resets to 200%, login window is offscreen but when you wake the system hit ESC, password, ENTER to login).
  2. Area screenshot (practically impossible to do, no solution).
  3. Apps like DigiKam (appimage) and Elektron app like OnlyOffice DesktopEditors have extremely tiny cursor (no solution).

I hope Budgie 11 (Wayland?) Is released soon and will be used for the next version of Ubuntu Budgie.

In a first test it has not worked well but it may have been my mistake, tomorrow I will look at it with more time and notify of the advances but I hope it can be fixed for the next version, because certainly those of us who use linux do not find it difficult and even I like to be using commands in the terminal but having to spend hours and hours looking for a solution for something like that is a bit annoying. With that I am not saying that the system is bad, it is a marvel and I especially love the design and customization thanks to the app “design and budgie themes” and the applets but it must be said everything, the good and the bad.

I may know of a better or simpler way to implement fractional scaling via xeventbind on github. I will write it up later and update that thread of mine that fossfreedom linked to at some point.

I discovered another potential way to fix it due to working an issue out with the Plank dock. Will be creating a thread for that in a moment.

Thanks, when you can I would like to try the method, it is a bit annoying to have such a small scaling.

You can look at this thread for an idea of how to use xeventbinds.

Thanks for the help, I still didn’t get it to work well but I appreciate that hyasa took the time to help me.