How to Connect to Windows Networks Shares from Ubuntu budgie Desktop

I am new to ubuntu budgie. I installed ubuntu budgie 19.10 on dell optiplex 7040. I am happy with it. I have a problem, connecting to windows network shares. Could you please help me out.

Wait… where is my crystal ball ?

What did you try so far ?

Do you see your Windows Network Shares in the « network » section of Nemo ( your file explorer ), in its left panel ?

Thanks a lot for your help. This is a picture that I go so far.


hope you can help me. Thanks.

002
after that I can not see any computer in windows network.

sorry if my question will seem idiot, but … do you have anything shared on Windows machine? I don’t think that - unless you have configured it in regedit - nemo (or nautilus) could be able to see administrative shares …

Sil

You may have to install nemo-share and then mount the windows network which I am not familiar with. sudo apt install nemo-share

Admin shares are usually prefixed with a $ and are hidden from browsing. You need to know the share name and manually enter it in.

If I remember correctly - nemo-share is actually an extension to share a folder FROM your Ubuntu Budgie install. Not access a share on another computer.

What happens if you open Nemo, and then press the toggle location button (1), and then enter the path to your share (2) manually?

There is nothing extra you generally have to do. Can any other machines access the same Windows share? Are the Windows share configured properly and with permissions for the client to see the share? The other consideration is " Access Based Enumeration". (Hides a folder/file if you do not have permissions to it). The one part I am not clear on is if current versions of the Samba client support ABE from a Windows share. I know you can set it on a Samba Server and leverage the feature on a Samba client.

Note - If not aware, Samba is the software on Linux that implements the Windows file share features.

1 Like

I would not say you’re wrong about that, but if shares are correctly set on windows side, they should appear effortlessly in the Ubuntu file explorer, under

\ Network
 \→ Windows Networks
  \→ there one folder by workgroup

This works with « classic » windows network shares - this won’t work with « residential » network
( not sure of the correct english term here sorry ).

As @puffettacicciottella mentioned, if no shared folders are set on the windows pc, nothing appears there ( hear : only the shared folders appear, not the « whole » pc ). If windows PC are 7 or 10, the regedit trick is no longer needed ( for what I remind from my work place, it’s been some weeks I have not gone there… )

When clicking on one of this shared folder, it may ask for id and password, depending on how the share has been set window side. It’s id and pwd as meant on windows for the user of such shared folder, not the local Ubuntu ones.

Thanks for clarifying, I do know that the network needs to be mounted once available. I’m on a Windows network, but with sharing disabled as result I receive a failure to mount network error.

yeah, that’why I’ve mentioned them: if he hasn’t anything shared on windows he won’t see anything right because admin shares must be configured before on windows side (via regedit) and pointed manually.

as far as I know (I’m obligated to run a win10 pc to do some dirt job on AD, at work, job that could be done also from linux via shell, powershell for linux and ldap-tools, but I’m lazy, so for some stuff I prefer woking directly from windows), to enable adminostrative shares one must create a key (localAccountTokenFilterPolicy) in hkey local machine -software -microsoft-windows-currentSomething(I don’t remember, now)-policies and set it to 1.
In 7 and i 10 too. But it’ possible that I’m just used to that and it’s useless … not such a great windows admin :slight_smile:

Sil

1 Like

Let’s say I also don’t trust my memory :sweat_smile:

I perfectly remember having to deal with regedit for windows share being seen on Linux boxes. But it sounds like a couple years ago.

Recently I did not need to do that - but here is my doubt - maybe, probably, I had already done it on some windows boxes :crazy_face: and I can’t check right now.

Anyway what remains certain is the windows shares need to be properly set on windows side before being able to see them from Linux boxes.

Thank you so much for your support. I will try everyone of your advice. I will let you know my progress.

c’est nickel! :smiley:
(I wanted just write the upper line, but a popup prevented me posts must be at least 2 chars long … :grin:)

I could be wrong on the registry stuff. It has been soem time since I have had to work in that type of environment.

Thanks, that helped me a lot!