How to turn off monitors after x mins idle

As the title states, how would you do this? There’s no option under the power settings, only “dim screen when inactive” which doesn’t seem to do anything and “blank screen” which does work but doesn’t turn off the monitors. I don’t want to suspend the system.

Anything here that helps?

Not really. I want the monitors to switch off after x minutes system idle, rather than turning them off manually.

odd - I’ve seen various threads like this (https://forum.antergos.com/topic/4228/monitor-no-longer-power-s-off-with-screen-saver/7) - they mention that some blank with time options turn off the monitor - others don’t e.g. setting to 2 minutes works where as setting to 10 minutes doesnt turn off the monitor.

It works fine here, but to find a workaround: does the command xset dpms force standby turn off the screen (standby mode)?

Sorry everyone but i’m a complete idiot. Suddenly remembered I installed caffeine months ago and forgot all about it. doh

I’ve been in places like that :slight_smile:

I would like to add one solution to the problem that was posted here… While I was using Ubuntu Budgie 18.04 until recently I did not have any problems with my screen to turn of after X minutes. But when I switched to Ubuntu Budgie 20.04 few days ago, I had exactly the same problem as @kingfu described here. I must say I spent many hours searching for the solution. So I would like to share solution that I finally made for this just in case someone else bumps to this problem in 20.04.

So, lets start at the begging.
Problem: Very simple, I would like my monitor to turn off after 30 min of inactivity.
Usage: Usually I dont turn of my computer for weeks, but I would like that my screen is off as soon as I stop using my PC for some time (lets say 30 min).
Default settings: First in Ubuntu 20.04 (Budgie for sure, but I don’t know if this is the same in standard Ubuntu 20.04) you can find only these settings for the screen:

  1. Go to Settings - Privacy - Screen lock, and you will find Blank screen delay, auto screen lock delay.
  2. Go to settings - power, you will find Power saving (Blank Screen) after x minutes

Neither of these settings turns off the screen!
Failed attempts: First I tried turning off Caffeine as this post was my starting point, and It doesn’t work. I tried also uninstalling that app, and it didn’t help. Next I searched on internet for the solution, found many different answers but not for Ubuntu 20.04. Many of them included instructions how to change xorg.conf.d file which I was unable to locate on Ubuntu 20.04 as it should be in /etc/X11/xorg.conf.d/. I realized this should be the best solution since it was mentioned on a few places, but I couldn’t find way to change these settings for the monitor since file does not exist. I tried also using xset command in terminal to turn on DPMS but it didn’t work (dont know why since I had fresh install of the Ubuntu). This was probably the biggest problem for me since I found many instructions where it was written that this command should work (I tried with sudo but didn’t have any luck there).

Solution: After I found that xorg.conf.d is now in the /usr/share/X11/xorg.conf.d I added a new file in that dir (you will need admin privileges for this) with the name 10-monitor.conf with the text given below. So you will need to do this:
First you can see current settings by typing xset -q

cd /usr/share/X11/xorg.conf.d/
sudo gedit 10-monitor.conf

paste this code in the file 10-monitor.conf

Section "Monitor"
    Identifier "LVDS0"
    Option "DPMS" "true"
EndSection

Section "ServerFlags"
    Option "StandbyTime" "5"
    Option "SuspendTime" "5"
    Option "OffTime" "10"
    Option "BlankTime" "0"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
EndSection   

Type xset -q again to see changes.

This solution is based on this:
https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling
Be aware that this solution enables Display Power Management Signaling and you can change Options for StandbyTime, SuspendTime, OffTime, BlankTime all values are in minutes.

I hope this will help someone else who has similar problem as me, but if this is not good as solution (I am not expert and I don’t know if this is optimal solution or not, but I know this worked on my PC) and off topic I guess admins will remove it.

2 Likes