Insert a video DVD does not launch VLC


here my settings :

but when I insert a video DVD nothing happens.

I have to browse to the DVD through Nautilus and there it suggests me VLC.

Seems like DVD is not mounted at first ?

No one ? :grinning:

Should I try without the « places applet » ?

I don’t use VLC … just wondering - if you use Disks and use the “mount at system startup” option for the DVD drive - does VLC then automount?

You must install the DVD playing software pkg!

EVERY time I reinstall a distro, I forget to go through this nonsense, and also: installing the driver to allow exfat USBs. Ugh.

Thanks Jason but it’s ok for playing the dvd.

Problem here is : when I insert the dvd, it is not automatically launched-and-played through my video player software.

If I manually browse through files explorer to the folders on the dvd, I can play them.

( and it’s not nonsense, it’s a license problem : those decrypting utilities can’t be distributed by vendors/distro-maintainers, they even are forbidden in some countries. Quite a similar issue for exfat. )

… fair enough, but I still wish it wasn’t an issue I had to resolve every single time. Isn’t Linux pals with Windows these days?

Well, setting dvd-player-device as automount through disks does not change anything.

When I insert DVD I have to open the files explorer, then launch VLC.

I’d expect VLC ( or any other video-player set to be default ) to open automatically right after inserting that kind of DVD. Or at least the files explorer to open automatically.

I think this is the same wish here → ( french )

1 Like

Strange, setting automount works for me… I use GNOME MPV as my video player.

Any inconsistency here maybe ?

Try setting all DVD options in Autres medias (other media?) to VLC.