Installing Chinese - pinyin via ibus

I use a Laptop with TuxedoOS, that builds on top on Budgie. I want to be write Chinese, that I use regularly, at least once a week.
I did it wvia the region and language setting, using ibus. Than I added intelligent pinyin.

I can type Chinese, but not see the suggestions, it’s like running blind.

It’s very import to so the suggestions because similar sound my still be different Chinese Characters.
I tried to solve the problem for some weeks now. Steps taken:

  1. removed intelligent pinyin, and reinstalled. → nothing happened
  2. removed intelligent pinyin, and it’s setting files. ->nothing happened
  3. tried different pinyin. → same problem
  4. export XMODIFIERS="@im=ibus"
    export GTK_IM_MODULE="ibus"
    export QT_IM_MODULE="ibus"
    → nothing happend
  5. installed xubuntu-desktop side-by-side: after setting up intelligent pinyin there, it works on the xubuntu dektop, but than switching to budgie, it doesn’t work. → Is it desktop specific? On Xubuntu when turning on intelligent pinyin, some extra setting icons, for chaning the setting. On Budgie (same Laptop) nothing happens. No suggestions, no extra icons, just typing “blind”.

I am pretty desperate. How can I set it up, so that I can write Chinese properly without changing the dektop?

I’ve just received a Tuxedo laptop a couple of days ago. I really dont recognise what they have done - it is built from their own packages and doesn’t appear to use normal Ubuntu bits and bobs. Tuxedo OS lasted approx 30 minutes before I wiped it and installed 20.04.2 & 21.04 Ubuntu Budgie.

As such we cannot support their OS. Support for Tuxedo OS should be via Tuxedo themselves.

As to input methods - I cannot answer your question directly other than to make you aware there are two input methods - ibus and fcitx. By default ibus is used by GNOME/Budgie. You can also install the fcitx packages if that works better for you.