Home Store Blog

Issues with upgrading


#1

Hi all, recently apt list --upgradable started to return:

Listing… Done
brave/bionic 0.22.727-1 amd64 [upgradable from: 0.22.721-1]
libcuda1-390/bionic 390.59-0ubuntu0~gpu18.04.1 amd64 [upgradable from: 390.48-0ubuntu0~gpu17.10.3]
liblouis-data/bionic-updates,bionic-updates,bionic-security,bionic-security 3.5.0-1ubuntu0.1 all [upgradable from: 3.5.0-1]
liblouis14/bionic-updates,bionic-security 3.5.0-1ubuntu0.1 amd64 [upgradable from: 3.5.0-1]
libvulkan1/bionic 1.1.73+dfsg-1~gpu18.04.1 amd64 [upgradable from: 1.1.70+dfsg1-1]
libxnvctrl0/bionic 396.24-0ubuntu0~gpu18.04.1 amd64 [upgradable from: 396.18-0ubuntu0~gpu17.10.1]
nvidia-390/bionic 390.59-0ubuntu0~gpu18.04.1 amd64 [upgradable from: 390.48-0ubuntu0~gpu17.10.3]
nvidia-opencl-icd-390/bionic 390.59-0ubuntu0~gpu18.04.1 amd64 [upgradable from: 390.48-0ubuntu0~gpu17.10.3]
nvidia-settings/bionic 396.24-0ubuntu0~gpu18.04.1 amd64 [upgradable from: 396.18-0ubuntu0~gpu17.10.1]
python3-louis/bionic-updates,bionic-updates,bionic-security,bionic-security 3.5.0-1ubuntu0.1 all [upgradable from: 3.5.0-1]

When I tell it to upgrade though it replies back:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-390 : Conflicts: xorg-driver-binary
E: Broken packages

I’m running Budgie Ubuntu 18.04


#2

In Software & Updates - Settings - Ubuntu Software tab have you got the “restricted” repository ticked? It should be.


#3

Thanks, that did fix the issue. However (perhaps unrelated) Civilization V plays really slowly when moving people around.

Chris


#4

@GrindamN ^^^ game for you to check whilst testing