Japanese no longer working

Hello

I installed UB a while ago and I like it a lot (as I couldn’t get Solus to work on my new hard drive). Back then everything worked fine, but now I’ve noticed that my Japanese setup no longer works. I’m using ibus and mozc, but now it doesn’t show an icon for changing alphabets when choosing Japanese language. I was able to get it to appear by typing “ibus-daemon -drx” in the terminal, but even though I can change to Hiragana etc it still writes in latin. More specifically in Swedish.

I have been using Linux for several years, but am in no way an expert. I have always had problems with getting Japanese to work (why oh why must it be so damn complicated? If one wants Japanese, don’t first give them a crapload of non working options, just use one that bloody works and stick to it!) but at least it worked on Manjaro. It didn’t work on Elementary either actually.

Anyway, I need Japanese to work so any suggestions are welcome.

What version of UB are you using?

18.04 LTS. I forgot to mention that.

Have you got the application indicator applet and the system tray applets added to your panel?

Think mozc icon displays on one of those applets.

No. How do I do that?

Open budgie desktop settings from the menu - click on your panel and check the list of applets displayed.

If they are not on your panel - click the + button to add applets.

I’m not exactly sure what to look for, but I have got the Keyboard layout indicator there. That got Japanese to work in the beginning. Now it just let you chose between languages the same way the language chooser does.

image

Have you got those two applets in your panel?

Yes, they are both there.

Does pressing Super + Space switch between keyboard layouts?

Yes, that works. I use it to switch between Swedish, Esperanto and Japanese. The two first works flawlessly. But Japanese is shown as JA next to the keyboard icon on the top and it writes only in Swedish. The Mocz icon does not show unless I write in the terminal the way I wrote above, it then shows up as a separate movable tray, but the problem remains unchanged.

hmm - sorry - that is the extent of my knowledge :frowning: I’m just an english single keyboard user.

Hopefully someone else will pitch in.

Additional support places also worth exploring at the same time are askubuntu.com and ubuntuforums.org

Thanks! I hope someone has a solution. Or at least you guys can find the problem and fix it. UG is a nice distro and I hate to have to switch because of this :slight_smile:

Please run these commands:

$ gsettings set org.freedesktop.ibus.panel show-icon-on-systray true

$ gsettings set org.freedesktop.ibus.panel xkb-icon-rgba ‘#ffffff

or you can enable IBus and input Japanese.

I hope you having fun.

Thanks, but that didn’t do anything. And I’ve already got ibus with mozc running. It’s not working is the problem.

Okay, I actually stumbled upon the problem and the solution. I started Language Support and it had some languages missing. I’ve always updated through apt-get so I thought such things were covered. I let it update everything.

Also, for some reason it had changed the Keyboard input method system to XIM. First time I used this setting I did choose Ibus. Changing it back to Ibus solved all my problems. Japanese works fine now :smile:

yay! brilliant news :slight_smile: