yesterday I had to format and reinstall OSs on a colleague laptop (I say OSs because she wanted windows and ubuntu in dual boot) and for the first time, installing packages via apt-get dselect upgrade based on a “certified” selections list (coming from my last qemu pc, last week I mean, not three months ago), I’ve got a break in dselect-upgrade with the error:
following packages have unmet dependencies:
libglib2.0-dev : depends: libglib2.0-0 (= 2.72.1-1) but version 2.72.3-0ubuntu1 is installed
Trying to downgrade libglib2.0-0 from 2.72.3 to 2.72.1-1 is suicidal, provoking complete removal of Budgie DE and other vital stuff; I’ve tried to investigate which package caused this behaviour and (among others … I’ve done a long apt-get install based on 5 packages at time until I’ve got the error) I’ve isolated Lazarus. Same error, for example, trying to install libosmgpsmap-1.0-dev
For having a complete proof, I’ve created a brand new vm in qemu, installed OS and then gcc and binutils and finally tried to install lazarus both via downloaded packages and dpkg and via repository’s packages and apt: same error.
Can someone help me? I can suppose that’s due to
in libglib2.0-dev dependencies; what makes me perplexed is that a week ago I’ve installed two laptops with the same selections list that now gives that error.
Thanks and have you all a nice weekend (I’ll read you next monday ),
That version doesnt come from the archive. So it must be from a ppa you have installed or you have installed a deb that has been built on this version?
Thanks fossfreedom. I was thinking about the fact that until … maybe last week or two weeks ago I didn’t meet any problem in lazarus installation, both from repo and from packages downloaded from Lasarus Project site but, as you made me notice, my sources.list is heavily modified; so I’ve downloaded a brand new budgie iso and installed it on a qemu VM. I didn’t touch anything from fresh install, just added binutils and gcc, needed by deb files.
Trying to install lazarus (both from repo and from deb), I got the same unmet dependencies error; giving a apt -f install simply removes lazarus, while trying to downgrade libglib2.0-0 to 2.72.1-1 version (using apt -s!!! ) has the result of removing the entire budgie DE, DE manager and other “vital” stuff (so I didn’t downgrade anything).
Then I’ve made another qemu VM from “standard” Ubuntu (gnome DE, I suppose) and configured exactly as Budgie one (no modifications after install, just addedd gcc and binutils): trying to install lazarus on this machine too, I’ve got the same error about libglib but giving a apt -f install solved the problem.
If I give a dpkg -l | grep libglib on both machines, I get:
libglib2-0-0 → 2.72.3 on Budgie
libglib2-0-0 → 2.72.1-1 on gnome
as you can see in attached screenshots.
Is it possible that this depends on (maybe) some recent Budgie DE upgrades? The two machines, besides DE, were identical.
Thanks and have a nice sunday,
EDIT: while dinner swordfish was cooking I’ve took a look to my husband’s Budgie, since ha has a very long update routine (here we say that he updates his pc every time a Pope dies … I can understand him, anyway, he’s a lawyer!): his outdated version is still running libglib2-0-0 → 2.72.1-1
ok - the recipe that I tried was as follows:
ubuntu budgie 22.04.1 ← i.e. the recent .1 release
sudo apt update
sudo apt full-upgrade
sudo apt install lazarus
I then checked dpkg -l | grep glib2 and 2.72.1-1 was only installed.
It seems strange … every trial above reported comes with budgie iso downloaded yesterday and today from cdimages.ubuntu.com; immediately after post installation reboot I get libglib2-0-0 → 2.72.3
Now I’ve downloaded budgie 22.04.1 from Downloads | Ubuntu Budgie and in this case, after postinstallation reboot, dpkg -l | grep glib2 has given 2.72.1-1; I’ve given an apt update; apt full-upgrade and libglib2 is still staying at its place
Another precisation: giving a file command on isos downloaded from ubuntubudgie.org and from cdimages.ubuntu.com exits in ‘Ubuntu-Budgie 22.04.1 LTS amd64’ in both cases, but on iso downloaded from second site, libglib2 version 2.72.3 is installed … curious, isn’t it?
Obviously, from now I’ll download isos only from ubuntubudgie.org!
Thanks a lot for your suggestion and have a nice sunday,
What I think has happened is that you were downloading the jammy daily image. This includes the 2.72.3 version of glib … which has now been deleted from the archive. It was apparently uploaded in error to jammy proposed.
Dailies include the jammy proposed being automatically enabled. Its only at release time such as the next 22.04.2 release when the proposed repo is disabled.
The daily hasn’t actually been rebuilt for a couple of weeks now - Canonical are aware - the next daily will have the expected v2.72.1 back in the proposed repo.
Thanks, fossfreedom, I suppose it’s gone that way … maybe my error will be useful for other people, hopefully.