New window opening under dock on LHS

Mostly just an annoyance to me, but I’d like to pass this on…

When I open a new window, be it a terminal or a file window, it always opens at the extreme LHS of the screen. This puts the LHS of the window under the dock.

New instances of the window are always placed just far enough to the right to miss the dock. In fact, the second window instance location seems to be pretty much where I’d like the first instance to be.

I don’t want to have the dock hide.

Is there a setting somewhere to make a window never open closer to the LHS than a few pixels to the right of the dock?

Probably this discussion helps

so you can use the dconf mutter settings to make most windows open in the center. Not all apps respect this setting though.

Files opens usually to the same size as it was last opened - so just make sure you dont have full width windows for Files when you close.

… and the custom method described in that answer also works!

I’m sorry, I’m a bit of a noob when It comes to how this is implemented.

I haven’t the foggiest of an idea how to use this or modify it’s parameters.

All I’m really hoping for is to not have program windows interfere with the dock. I don’t want them centred on the screen.

So far I’ve managed to:

Save the script file into ~/.scripts

Set permissions on the file to include execution of the file (not sure I needed to do this?)

Tried the command listed:

python3 /path/to/ as python3 ~/.scripts

Got this message:

/usr/bin/python3: can’t find ‘main’ module in ‘/home/gspat/.scripts’

Looking for a similar message on google it comes up as though I forgot to save the file… But I have saved it.

No idea what to do next, mostly because I have no idea how to work with python, and a cursory look to figure out what to do isn’t helping me.