New window shuffler is now available - feedback welcome

That’s cool, I’ll see if I can get a GUI in :slight_smile:

All. Nice video of the new shuffler capability has been added to the first post. Enjoy.

1 Like

NOTE:

For those who are testing the new WIndow Shuffler:

As a result of internal discussion AND because the options now include expanding to the left/up (expanding to the right already was included), the set of shortcuts was also extended and also partially changed.

We believe the new shortcut set for moving and resizing is more intuitive and consistent:

Quarter/half tiling / toggle maximize (not changed):
Ctrl + numbers 1-9, on keypad or main keyboard
---
Move (not changed):
Super + Alt + arrows
---
Resize - anchor on topleft (so expand/shrink to the right/down)/*:
Ctrl + Super + arrows
---
Resize - anchor on bottomright (so expand/shrink to the left/up) (<-new)*:
Super + Ctrl + Alt + arrows
---
Arranging all windows to grid*:
Ctrl + Super + A
---
Calling GUI grid:
Ctrl + Alt + S
----

*new or changed

I am trying the new shuffler today. Great work.

One thing I find difficult to achieve is closing or minimizing an open window, once the shuffler is enabled.

I am using the pixel saver app and with the shuffler enabled, the top bar does not auto-hide anymore and covers the close and minimize buttons of the open window.

For the moment, I use ALT+F7 to drag the window around and reach the close button. This also restores the auto-hide functionality of the top bar. But I find this inconvenient.

Is this intended? It was the reason why I didn’t use the old shuffler.

Also, is there a shortcut to unattach the window from the shuffler?

Is there a tool to capture a screenshot of the desktop with the open side-menu and open app-menu? PrintScreen and the Screenshot-applet seem unable to capture these details.

The thing we have to deal with is that with autohide on, the window manager returns the space of the panel to be available as work area, but it only hides on fullscreen or otherwise maximized windows (unlike plank). That is not the case on tiled windows.
Autohide and shuffler are therefor not a good combination. To use shuffler without that issue, please turn off autohide in the panel’s settings.

Capturing whole screen after a 6-8 seconds delay ?
Capture du 2020-01-27 23-21-04

Many thanks for your follow- up. From your answer I take it that including the feature is not possible.

Is this correct? Or is it too much hassle or not desirable?

Cool @Coeur-Noir, this is not Budgie’s screenshot applet, is it? At least, I can’t find the dialog or the options. What tool are you using?

I want to do capture a screenshot like this one here:

Well yeah. It seems the current panel’s autohide option was not written with automated window positioning in mind. If you look at Plank, it hides immediately if any window covers the area, while the panel only hides if any of the windows is maximized.
Switching autohide off fixes it though.

EDIT
correction. Panel’s Intellihide does the job, but indeed pixelsaver seems to clash with the intellihide option.

think in plank there are two options - autohide and window dodge. Just wondering if there is a difference in plank behaviour as well or is plank well behaved with both options.

its gnome-screenshot that has the delay option available.

Hmmmm, testing hiding, intelligently or not, with pixelsaver or not, is quite an unpredictable thing atm. It works on and off here.
The bottom line is: better switch it off if you would like to use shuffler.

Kindly consider my observations an effort to improve the usability of your great work. I find the shuffler very useful. It is just getting a little bit into my way if I have to switch off other applications before I can use it. One of the biggest advantages of Budgie is that it does not get into your way, like the gnome extensions, where you have to figure out witch ones work and how.

Maybe it is just my isolated opinions, so you can just disconsider.

I personally find it a little inconvenient to have to switch off the pixel saver or / and auto-hide to be able to use the shuffler. Maybe other users feel the same way. And maybe new users find the procedure confusing.

It’s probably a community thing : if lots of people would like to see the feature, maybe there is a way to implement it.
But I don’t know if it is even possible or viable from the technical standpoint. And, of course, it doesn’t make sense to put in a lot of work just to please a single user.

Don’t get me wrong, I’d like the panel to behave in a consistent way when it comes to autohide. Unfortunately, it is an upstream issue.

In the meantime, I have been playing a bit to create a workaround without changing the functionality of Shuffler. We could include a gsettings option to have a tiny marge around the virtual set of tiles, which results in the following arrangement:

Cool, you’re the man. Very creative.

When will I be able to test it?

Need to run a few tests on multimonitor if it behaves well. I will let you know soon.

I refined it a bit, so you can now specifically set a minimum top-margin shuffler should keep. If you have dconf editor installed, please set the top margin so that shuffler stays beneath the panel’s area.

I’ll include the option in Shuffler Control if we don’t run into any surprises. It seems to work fine though, also on multi-monitor and different scalings I tested.

I’ll push it later today, should be available after next build I guess.

I am testing it now. Many thanks for your efforts.

A post was split to a new topic: Shuffler keyboard shortcuts not working