Home Store Blog Development

Night Light enabled only on one external monitor - Redshift alternative works


#1

Activated Night Light Applet from sunset to sunrise.

It finally works after uninstalling Brightness Control Applet, but only on the left screen of the dual monitor setup.
:rofl:

Anybody seen the same issue?

pappl


#2

Seems to be a GNOME issue - https://bugzilla.gnome.org/show_bug.cgi?id=780167

Reading through on the linked issue https://gitlab.gnome.org/GNOME/gnome-settings-daemon/issues/6

it mentions killall gsd-color although the bug-report is closed saying that its fixed in mutter 3.28. So looks like there are more issues here with your setup - other people seem to be having the same issue on that report after the fix was released … so looks like it is not fully fixed.


#3

thx for your help.

The links show exactly my problem.

Did a killall gsd-color and now Night Shift doesn’t work on both monitors.
Tried changing color profile settings, turning off and on monitors, but still no Night Shift function.
:rofl:

I guess we simply have to wait for a fix.


#4

Night light doesn’t work, tried other tweaks today.

Instead i tried Redshift, but it gets a geoclue2 error, even with geolocation enabled in settings -> privacy.

It works with a redshift-config file:

Install Redshift:
sudo apt install redshift-gtk

Create redshift.conf to avoid geoclue2 error:
sudo gedit ~/.config/redshift.conf

( Redshift ver. 1.12+ looks for the configuration file in ~/.config/redshift/redshift.conf (or ${XDG_CONFIG_HOME}/redshift/redshift.conf ) if $XDG_CONFIG_HOME is set. The old location at ~/.config/redshift.conf is deprecated but still searched as a fall back.)

Paste this text into the redshift.conf file and customize your geolocation (google your city for lat & long):

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=6500
temp-night=3900

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=0

; Set the screen brightness. Default is 1.0.
;brightness=1.0
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=1.0
;brightness-night=0.6
; Set the screen gamma (for all colors, or each color channel
; individually)
;gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: ‘geoclue’, ‘geoclue2’, ‘manual’
; type ‘redshift -l list’ to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: ‘randr’, ‘vidmode’
; type ‘redshift -m list’ to see all possible values.
; ‘randr’ is the preferred method, ‘vidmode’ is an older API.
; but works in some cases when ‘randr’ does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type ‘redshift -l PROVIDER:help’ to see the settings.
; ex: ‘redshift -l manual:help’
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=48.0
lon=16.0

; Configuration of the adjustment-method
; type ‘redshift -m METHOD:help’ to see the settings.
; ex: ‘redshift -m randr:help’
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust all screens.
;[randr]
;screen=1

Log off and log in. Works on all screens! :sunglasses:
You may uncomment brightness-day, brightness-night to lower brightness too, but it starts to pulse brightness on my screens, so i left it commented (disabled).
pappl