No history saved in terminal

Hi I’m not that new to linux or Ubuntu but I AM new to Ubuntu Budgie. I have just done a clean install and I have found the terminal is not remembering any history. I’ve looked through its settings and can find nothing to to rectify this.

I know how to adjust the history size and clear it but I had no idea it could be disabled…

How do I fix this, please?

I have solved this, myself… I think. Poking around and checking the history file was there and what size it was using terminal commands:




has somehow tricked the terminal into behaving properly and the history has started to save of its own accord…