Not able to open the any settings from top right menu

Hi All Linux Experts,

I am a newbie to Linux, so sorry if my question is silly but any help is appreciated. :slightly_smiling_face:

I am trying to open the Bluetooth settings from the top right menu but it is not opening. It is coming to the dock and when I click it from the dock, a screen pops up and quickly goes to the right. Now when I press Alt+tab I can see it is open but not able to access it. The same thing happens when I try to open up the Sound settings which is right next to Bluetooth settings on the top right menu. Everything else in the dock works absolutely fine. For example, if I open up the browser it works beautifully.

I also tried opening the settings but no luck. Please help.

Hi and welcome!

From the menu, open Tilix

Type the following:


This should open “Settings”

If it doesnt, is there anything displayed in Tilix after running gnome-control-center ? Copy - paste the output here.

Thanks for your response.

I tried the command as you said and it did bring Settings icon on the dock, the same way it came to the dock when I clicked it from the top right menu earlier. But when I click on the Settings icon on the dock, a window pops up and quickly goes to the right of my screen. I am not able to access the screen.

Also I dont seem to get any error on Tilix, see snapshot below.

What am I doing wrong?

Just to update, while I found a workaround. I downloaded the Blueman Bluetooth Manager and that seems to work fine. Similarly, another Sound settings app from the Software seems to do the job. Not sure why the OS provided apps wont work.