Option to 'blank screen' or anything other than 'sleep' on closing lid

Currently Budgie doesn’t allow this sometimes annoying option to be switched off via the GUI. Are there any plans to include this?
Mate and other desktops offer this configuration option.

You could use a terminal command and assign it to a keyboard shortcut (or hotcorner)…

sleep 1 && xset dpms force off

That blanked my screen then as soon as I shut the lid (so that my MUSIC will continue playing through my bluetooth headset), it slept.

These options should be available through the GUI, surely?

This is an upstream question (https://github.com/solus-project/budgie-desktop). I’m not aware of it being asked before - nor are there any publicly available plans stating that will be made available.

It could/should be part of budgie-desktop-settings but if you intend to provide a patch I would touch base with upstream first.

It’s just one ‘use case’ but the real issue is:

How many options shall we let the user configure for:
Pressing power button?
Pressing sleep button?
Closing lid?

Having actively used settings in other distros that are not available to me in this distro, I can’t believe I’m the only person in the world who wants these features?

That link didn’t work, what is it?

forgot the .com

I would suggest that if you are proposing a patch then the options that are available via gsettings gnome-settings-daemon power management stuff now should be part of the GUI.

I think it should be as good as gnome, mate, and cinnamon, which all allow the user to configure this stuff easily through the GUI, usually accessed by clicking on battery icon in panel then choosing ‘power settings’.

are you sure GNOME Shell has such options?

Sorry I meant KDE not gnome!

Research tells me Mate comes from Gnome 2, and gets it right
Cinnamon comes from Gnome 3, and gets it right.

I haven’t looked at the way the vanilla gnome 3 desktop does it!
Budgie desktop seems to come from Gnome, so did Gnome reduce the feature set before Budgie inherited the design?

Hmm, my budgie blanks the screen on lid close without going to sleep or hibernating. In regards to settings: I did install “Tweaks” extra to the default installed settings. I’ll have a look later when I get home if I did something in that.

ah, which ubuntu tweaks?

Just checked latest KDE Neon live, their power management config is even more detailed. It allows you to select all appropriate options for power button and lid close, and configure them differently for ac power, battery, and low battery.
Going to check xfce next…

“Tweaks” can be found in the software center and has some extra options for settings. Some I can not live without.

KDE is not a reference from Ghome. The KDE developers are of the opinion EVERYTHING needs to be accessible from the GUI. The Gnome devs are 100% opposite: a user should not be bothered with settings :smiley:

I love Budgie for a couple of reasons and 1 of them is that they included a VERY good Budgie settings.

I am bothered by the settings.
They presume to know how all users operate, or care not about niche preferences.
Sure, by all means, default to something simple, but a box to tick for ‘more’ or ‘advanced’ settings can let the user have it both ways.

sure. but as I mentioned previously, this is an upstream discussion - not something we can handle here. Code patches always welcome to resolve - but discuss with upstream first.

Happy to raise it upstream, but where exactly is that please?

I already gave you the link in a previous reply.

Looked at that link, found a closed issue discussing it from 2016.
Installed gnome-tweak-tool and switched off the suspend on lid close…
Closed lid, no suspend but did get blank screen and total rfkill which I had to manually switch back on.
I just want the blank screen but no rfkill?

and total rfkill which I had to manually switch back on.
I just want the blank screen but no rfkill?

I had that too and managed to have my wifi active.

do you have a HP?

Yes an HP stream, got it cheap to play with. Have you?

Try the systemd thingy from https://askubuntu.com/questions/965595/why-does-airplane-mode-keep-toggling-on-my-hp-laptop-in-ubuntu-18-04

Works for me on my HP Omen

1 Like