Problems with xrdp


I’ve got problems to get xrdp run proper on budgie. I love budgie and don’t want to switch the GUI. Here are my steps what I’ve done so far:

  • installed xrdp
  • added a user named xrdp
  • added a rule for the ufw allow port 3389
  • edited the /etc/xrdp/ file. Added /usr/bin/budgie-desktop to the end of the line that starts with test -x
  • restarted xrdp
  • tried to login from Windows Remote desktop, but unfortunately I’m always getting an error message like “Remote desktop isn’t able to connect!”

hopefully someone can help me. Thanks!

This is the script we use on our raspberry pi version of ubuntu budgie to enable xrdp

it should also work on the standard desktop.

If your goal is to share the local desktop session, just install xRDP and x11vnc (disable the built in vnc via Settings > Sharing > Desktop).

And slightly modify the vnc section like in my /etc/xrdp/xrdp.ini (most importantly, port should be 5900):
Homeserver/xrdp.ini at master · zilexa/Homeserver · GitHub
Note this is the default xRDP.ini with just the xVNC section modified and loglevel set to warning instead of debug.

That’s really all I had to do. xRDP is faster than vnc, but to connect to the local desktop session it requires x11vnc.

It beats Anydesk and TeamViewer easily.

thanks a lot for the help!
with the script I managed to run the Remote Desktop at least over LAN, if I connect the client directly with the server. Unfortunately not yet over the internet. But anyway, thanks a lot. I am a big step further.

Thanks also for your solution #zilexa. But my goal is to work remotely over the internet from a laptop on the server.

Connecting over the internet is certainly very interesting thing to try.

Some obvious things to consider. What is in between your internet connection and you server?

Firewall, router, something else?

You are obviously trying to connect through a DNS entry or a specific IP address. At a minimum can you ping the server?

VPN may help here.

Then you need to consider what maybe blocking the xrdp port. Are you proxying? That is tricky to setup correctly.

Well done on connecting successfully over the LAN. Your issues are now basically network related not software.

Well, the provided solution works. Even remotely. Just a matter of exposing the service (port forwarding) and deciding on how to handle authorisation and security.

I would simply use Wireguard VPN and nothing else. But xrdp has authentication options.

I also run Guacamole on the same server. It even supports 2FA. But I didn’t expose Guacamole either. Should work via VPN as well.

WireGuard can be 70% faster than OpenVPN, obvious choice if you go that route.

With Guacamole, regardless of where you are and on what device, you can always connect via VNC, SSH or RDP by simply browsing to your Guacamole web UI and connecting to any (other) system with those remote services exposed. No need to install a client on your laptop or whatever you use when remote.