Reinstall Vimix Theme

I would like to reinstall the vimix theme, because I have deleted some theme files that I would like to get back.

I tried it with “sudo apt install --reinstall vimix-theme” , but I’m getting the error “Unable to locate package vimix-theme” .

What would be the proper way to call the package?


sudo apt install --reinstall vimix-gtk-themes

Thanks for the swift reply. This is what get:

“Reinstallation of vimix-gtk-themes is not possible, it cannot be downloaded.”

Please rerun sudo apt update again - I noticed that the disco package was missing!

I’ve also double checked upstream and note there is a new version pending so I’ll get that out as an update today/tomorrow sometime.

I tried that right away:

sudo apt update
sudo apt install --reinstall vimix-gtk-themes

I am still getting the same error message as before: Reinstallation of vimix-gtk-themes is not possible, it cannot be downloaded.

Have you got our backports PPA enabled?

I have this in the software sources: disco main


What is the output of the following?:

sudo apt update && sudo apt dist-upgrade

here is the full stack:

Hit:1 disco InRelease
Get:2 disco-updates InRelease [97,5 kB]
Get:3 disco-security InRelease [97,5 kB]
Hit:4 disco-backports InRelease
Ign:5 stable InRelease
Hit:6 bionic InRelease
Hit:7 stable Release
Hit:8 disco InRelease
Hit:9 disco InRelease
Fetched 195 kB in 3s (74,8 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

umm … dunno - just tested here on disco and sudo apt install vimix-gtk-themes worked just fine.

I have tried, a couple weeks ago, to install a bionic package (slingscold launcher) on disco dingo, with the following “trick” from here


You can change the repo entry to use bionic instead of dingo with the following command and it will work fine.

sudo sed -i.bak ‘s/disco/bionic/g’ /etc/apt/sources.list.d/noobslab-ubuntu-macbuntu-disco.list

it also makes a backup of the original dingo entry for you if the repo gets updated.


Could this be the source of the problem? How would I revert?


Try running:

sudo apt-get clean
sudo apt update
sudo apt install vimix-gtk-themes

The apt-get clean will delete all current references to downloaded packages - and then the update will refresh the list again so that hopefully it will start to recognise that vimix-gtk-themes exists in backports.

Trying out a few commands here:

sudo apt install vimix-gtk-themes  

shows the following output:

vimix-gtk-themes is already the newest version ( 

I guess it is the wrong entry : Noobslab

I probably messed something up when trying to install a theme from noobslab.

I guess I did something like

 sudo sed -i.bak ‘s/disco/bionic/g’ /etc/apt/sources.list.d/noobslab-ubuntu-themes-disco.list

(I knew it would come back and bite me).

ahhhh – ok - yeah. NoobsLab have a binary package name that trumps Ubuntu Budgie’s vimix theme binary package. That explains alot.

 sudo sed -i.bak ‘s/disco/bionic/g’ /etc/apt/sources.list.d/noobslab-ubuntu-themes-disco.list 

is something I found on the the net, without actually knowing the impacts (stupid me). How can I revert to the Budgie backport? Budgie's vimix the is a lot better ... 

the easiest way would be to disable the noobslab ppa via “Menu - Software Updater - Settings”

Then purge the vimix package you have installed

sudo apt purge vimix-gtk-themes

Run an update and install

sudo apt update
sudo apt install vimix-gtk-themes

That worked, perfect, thanks. I had the hunch to delete the noobslab entry from the software list. The missing part was purging the vimix package.

Everything’s a peace of learning and better understanding how Ubuntu works. Thanks a lot for your patience.

1 Like

Latest vimix theme from upstream has now been uploaded to backports.

Just update as normal.

Cool … I like Vimix, because of its simplicity.