Rtl8811au cd installation on budgie 18.1

This Q&A?

I’ve been down that road a dozen times last night - hence my anger at the wifi usb device…

surferjoe@UbuntuBudgie:~$ sudo apt install dkms [sudo] password for surferjoe: Reading package lists... Done Building dependency tree Reading state information... Done dkms is already the newest version (2.3-3ubuntu11). The following packages were automatically installed and are no longer required: linux-headers-4.18.0-10 linux-headers-4.18.0-10-generic linux-headers-4.18.0-17 linux-headers-4.18.0-17-generic linux-image-4.18.0-10-generic linux-image-4.18.0-17-generic linux-modules-4.18.0-10-generic linux-modules-4.18.0-17-generic linux-modules-extra-4.18.0-10-generic linux-modules-extra-4.18.0-17-generic Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded. surferjoe@UbuntuBudgie:~$ git clone https://github.com/zebulon2/rtl8812au.git fatal: destination path 'rtl8812au' already exists and is not an empty directory. surferjoe@UbuntuBudgie:~$

I have no idea what all that info (above) means. Do I have it installed? - and if I do, it certainly isn’t working even after three reboots.
I tried every permutation of github, repositories and such and at this point I just want to somehow get the code off the CD and install the driver from there.

I accidentally did it once - I know it can be done again but I fail to remember how.

FWIW: My Linux-pro just got married last month and is on a 'round the world honeymoon and I am all alone to try to figger this out. At eh mo, I am running on an Alfa AWUS036H, but that is needed on my RaspberryPi.

I will honest with you. I am not a wifi person. For my USB wifi I tend to buy cheap Ebay devices for the price of a decent coffee to escape issues such as yours.

Do check that booting with your previous kernel still works with your USB device

I.e. immediately on boot press and hold the shift key or press escape to display your grub screen

Choose the advanced option and choose a kernel you know worked.

If it doesnt then it is something else that you have done inadvertantly.

Since this isn’t budgie specific my thoughts here is to seek out help with a similar question on ubuntuforums.org and/or askubuntu.com where a wider audience with more experience can help.

What about allowing Ubuntu to load the driver for you? I hope your laptop/machine has an ethernet port and that you have an ethernet cord lying around. Plug it directly into the modem and ask the Ubuntu software centre to find the correct wifi driver for your machine. (I don’t have Budgie open in front of me, perhaps it’s called Drivers in the pull down menu, search in the “All” section) It will see you are looking for drivers in general, and then find the correct wifi driver for you. You have to allow it, then reboot to let the driver settle in. At that point you could unplug the ethernet cord from the modem.

FYI, if you don’t have that sort of set up at home/work, try the public library or your pal’s house.
Good luck! Wifi drivers have become less tricky over time, but I certainly hear your frustration.

Unless… does your wifi dongle plug into your ethernet port? That might be problematic. I hope it’s a USB wifi. FYI, that long gobbley gook output text was merely relaying you have successfully updated your linux kernel (congrats!) and that the machine can certainly see you have a wifi device attached. You need to plop the driver into place to allow the two parts to work together.

PS congrats on your friend’s marriage :slight_smile:

If you actually need rtl8812au driver then it’s to be found in official ubuntu repositories : https://packages.ubuntu.com/search?keywords=rtl8812au-dkms&searchon=names

…so Jason’s piece of advice sounds fair : get a wired connection, and install it.
If « the app-store » does not help ( can one install driver with it ? ) then it’s only that one short command :
sudo apt install rtl8812au-dkms
that may help.

Problem here : you probably tried to compile the driver from sources, I hope this past attempt will not interfere with that later regular installation.

( some examples video : https://www.youtube.com/results?search_query=ubuntu+18.04+rtl8812au-dkms )

FYI (Now that I’ve looked) Connect your laptop to the modem with the ethernet cable. Go to the application menu and search for “Additional Drivers” (it’s a green looking square. I guess like a circuit board?) With the ethernet allowing you to go on-line, it should populate the driver window with a couple of choices, including a Broadcomm multi-purpose driver and (?) a couple of other choices. Pick the one it prompts you to use and try that one. The little icon for wired/wireless ought to flicker between the two and then at that point you will able to delve into the wifi settings and set your password access.

I believe this is how you get/activate most drivers in general, including GPU/audio. I think Pop!_os has an install .iso with the Nvidia drivers preinstalled? (Boy, I’d love one of those Thelio machines! > crush!<)

If it’s very persnickety, your install may ask you to reboot to fully seat the wifi driver.
Report back once you’ve had a go at this! :slight_smile:

I bet that’d work OK - but this is a desktop and it’s about 50 feet from the modem. I don’t own a laptop.

I could get a CAT5e cable and give it a try - but the longest one I have is barely 8 feet long. It would be messy to move this desktop unit into the same area as the router. The WiFi cable going into the router is only just able to get the router up on a high shelf.

Why is Budgie so unlike Ubuntu Studio - where the correct driver was already in the distro?

well, try it without the ethernet. I was thinking it wasn’t present, but the “Additional Drivers” was right there in my pull down menu in the Applications. It very well may be installed just not turned on.

What a kick in the pants would be, eh? report back when you find out.

Nope. My problem is still here - and after I take my meds I might try it again - but really…that’s just frustrating as all to me because I know that the installation CD works, but I cannot remember the syntax of it to get it to do so.

Here’s what the CD looks like when I check the contents:

I know I accidentally installed it once - but I’ll be d@mned if I can make that mistake again.

I’ve tried this a number of times too:

[quote] ```
sudo apt update
sudo apt install git
git clone https://github.com/gnab/rtl8811au.git
sudo cp -r rtl8811au /usr/src/rtl8812au-4.2.2
sudo dkms add -m rtl8811au -v 4.2.2
sudo dkms build -m rtl8811au -v 4.2.2
sudo dkms install -m rtl8811au -v 4.2.2

.... and lately I've been getting this - 
and although I can run Netflix and Pithos, 
this keeps on telling me that I have an
internet connection problem - although i 
don't see how that can be: 


Okay first off, that is a very interesting layout on your desktop.

The contents of your disc looks very promising. What does the read me say? Dig around – If you can find a .deb file with the right driver name, double click it and gdebi or even the Gnome Software Centre will install it for you, even though you aren’t online.

OR for goodness sakes, go to the Staples and buy an ethernet cable. Kijiji? Some sort of active surplus electronics store? It sounds very frustrating, and it seems like you might solve it with a 50’ length of cable.

Hey WAITAMINNIT, how are you reading this on the internets?!! You said your modem wasn’t working! Do you have TWO computers?

hee hee

…this sounds weird. If it worked out of the box with another Ubuntu, it should work the same with Budgie. Drivers are not variant matter, they are or they are not in the linux kernel.

If not, you may install them from your distro repository, and at very last case, compile them from source ( and then you’ll have to repeat that on each kernel update - unless there is a dkms method for the driver ).

Do you have any other device connected to internet ? If so you might download the .deb package from here ( for ubuntu 18.10 ) it’s from the page mentioned above package size is 1,089.6 kB so not a big deal, it could even fit into an email attachment.

What is your situation now, regarding wifi and internet ?

Sorry about the delay in responding - but I had shoulder surgery for a rotator cuff and didn’t really feel like typing.

To the problem: yes - I have an Alfa Network dongle running - it seems to be able to run on anything I install and distro-hop with. It’s fantastic - but I need it for my Raspberry Pi and want the RTL8811AU to run here on Ubuntu - like I had it running once upon a time.

I’m still trying to find a 50’ Cat cable - so far, not very fortunate in that area.

I hate to say it but your IT pal must be back from his honeymoon by now.

It’s kinda hard to tell… there’s a Do Not Disturb note on the front door and all the curtains are closed. My guess is that he had a long dry spell.

To my problem… today I’m creating a headless Raspberry Pi to stream Pithos into my guitar shop… so things may go somewhat mellower for me for a short while. I may have to break down and buy another Alfa unit…

Music, as they say, soothes the savage … er… is it “beast” or "breast "? Either way, consider it and me as soothed.

I’d still like to solve this rtl8811 problem, which I KNOW can be done.

OK — I solved it…

I wound up on the ARCH WiKi and found a sequence that - when I slightly modified it - it mran from the start of just plugging in the USB RTL8812AU sick.


sudo apt install dkms
git clone https://github.com/zebulon2/rtl8812au.git
cd ./rtl8812au
sudo ./dkms-install.sh

After it runs - and even if you get notices that you already have this in the distro or that you don’t need to recompile it because it already is, etc… just keep entering and hit ENTER each time and go on to the next code line.

It will wait until you plug the ‘dongle’ in and it’ll take right off without a reboot or cold start.

There’s a yellow card partially covering this letter I’m writing and I cannot tell if there’s any tyupos on the right side of it or not. Sorry - but I don’t know how to get that yellow notoice off the screen - there’s no “X-out” on it and a release of any sort that I can find.

Out Damn Spot!

awesome Mr TroutSurfer! Who needs your IT guy?

I’m amazed at the syntax in the command lines that I used. I’m not totally sure what happened - as some of this stuff is Vulcan or perhaps Klingon to me… but I’m learning.

“cd” means ‘change directory’ —> right?

I was worried that all the attempts I tried would still be in the driver zone and might screw up the running of the new RTL unit. Should I be concerned?

“cd” means ‘change directory’ —> right?

You are correct! :+1: