Today's update to 5.3.0-24-generic results in kernel panic on boot

Machine is Dell XPS 15 7590. Halts at the first Budgie graphic. Suggestions other than booting with older kernel? Tried one of the debug options and it notes a kernel panic.

1 Like

I just unintentionally upgraded to 5.3.0-24 and it seems fine? Perhaps it has been solved in these 7 hours … Can you purge it and retry?

Kernel panics need to be reported to launchpad - so boot with an older kernel and run:

ubuntu-bug linux

Then reboot into grub and for the current kernel that is causing the kernel panic remove the “quiet splash” and boot into the kernel panic - take a photo of the panic and attach it to the bug report on launchpad.

The bug triagers will ask you to verify if using a newer mainline kernel resolves your issue - this will give the kernel developers a better view of where to look

Tried this and been getting server errors during the upload process. Will try again later.

I have tried several times to do the ubuntu-bug linux but the process is not working. Apport collects the information and I do the send but “A new web browser tab will open to continue processing the bug data.” never happens. Suggestions?

Raise the bug manually on the linux package via your web-browser.

When you submit the bug report you will get a bug number.

Then run the following:

apport-collect bug-number


apport-collect 1234567

This will attach the logs to your bug report for you

I swear, this is not a easy process.

janice@Janice-Dell:~$ apport-collect 1855264
The authorization page:
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.
Waiting to hear from Launchpad about your decision...
dpkg-query: no packages found matching linux

grrrr … stumped - best add that to the bug report also so that the triagers are aware.

I noticed there is a proposed new kernel now in the eoan proposed channel - if you are up for testing then give that a go

Haha, with my luck I will mess something up, It is my wife’s laptop so will wait for it to be released.

How would I go about installing the prooposed kernel?

Run software-properties-gtk and the last tab there is a developer checkbox - this is the proposed repo.

Tick it. Then close the app.

In a terminal run

sudo apt update

It should say there is a bunch of stuff to install - DONT do a sudo apt upgrade. The message will also say there is a command to list what would be installed. Run that command.

Look for everything that says “linux” in the name.

Install those packages i.e. sudo apt install linux-modules-5.3.0-25-generic and similar packages.


finally - go back into software-properties-gtk and untick the developer checkbox

Installed the proposed kernel but that did not fix the problem :frowning:

that’s a shame :frowning: please let the triagers on your bug report know the current status (if you haven’t already done so!)

Just for the heck of it, I downloaded the UB 20.04 daily and tired it on a usb – live booted just fine.
Unfortunately, I can’t remember if this machine was a clean install or an upgrade from 19.04.

Looking through the apt history it came on-line in Sept and was upgraded. So, when I get time I will do a clean install of 19.10 and see if the problem goes away.

Re-install of 19.10 fixed the problem.

huh? that doesn’t make sense to me. oh well - it works - so congrats.

This laptop has the new Intel Killer Wifi chip that 19.04 did not support. A fix was to use backport-
iwlwifi-dkm package. The update to 19.10 worked fine but the kernel panic was caused by this package. If I had removed it the 5.3.0-24 kernel would have worked.

1 Like