Crash after kernel upgrade - Ubuntu Budgie 22.04 lts

Below are my details

apanta@apanta-desktop:~$ inxi -FZRa
  Host: apanta-desktop Kernel: 5.19.0-32-generic x86_64 bits: 64
    compiler: N/A parameters: BOOT_IMAGE=/boot/vmlinuz-5.19.0-32-generic
    root=UUID=8d3fddc3-603e-4cdb-aab2-62bd896da1d0 ro quiet splash
  Desktop: Budgie 10.6.1 info: budgie-panel, plank, vala-panel
    wm: budgie-wm dm: LightDM 1.30.0
    Distro: Ubuntu 22.04.3 LTS (Jammy Jellyfish)
  Type: Desktop Mobo: ASRock model: K10N78FullHD-hSLI..
    serial: <superuser required> BIOS: American Megatrends v: P2.30
    date: 04/30/2010
  Info: model: AMD Athlon 64 X2 5200+ bits: 64 type: MCP arch: K8 rev.F+
    family: 0xF (15) model-id: 0x6B (107) stepping: 2 microcode: N/A
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 256 KiB
    desc: d-2x64 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
  Speed (MHz): avg: 1000 min/max: 1000/2700 scaling: driver: powernow-k8
    governor: schedutil cores: 1: 1000 2: 1000 bogomips: 10799
  Flags: ht lm nx pae sse sse2 sse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA C77 [GeForce 8200] vendor: ASRock K10N78FullHD-hSLI R3.0
    driver: N/A alternate: nvidiafb, nouveau bus-ID: 02:00.0 chip-ID: 10de:0849
    class-ID: 0300
  Device-2: NVIDIA GF106 [GeForce GTS 450] driver: nouveau v: kernel
    alternate: nvidiafb pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports:
    active: VGA-1 empty: DVI-I-1,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 10de:0dc4
    class-ID: 0300
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:2 chip-ID: 046d:081b class-ID: 0102 serial: 23CC4900
  Display: x11 server: X.Org v: compositor: budgie-wm driver: X:
    loaded: modesetting unloaded: fbdev,vesa gpu: nouveau display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: VGA-1 model: BenQ GW2480 serial: E6N0327801Q built: 2022
    res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2 size: 527x296mm (20.7x11.7")
    diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: NVC3 v: 4.3 Mesa 23.0.4-0ubuntu1~22.04.1
    direct render: Yes
  Device-1: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
    vendor: ASRock K10N78FullHD-hSLI R3.0 driver: snd_hda_intel v: kernel
    bus-ID: 00:07.0 chip-ID: 10de:0774 class-ID: 0403
  Device-2: NVIDIA GF106 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 03:00.1
    chip-ID: 10de:0be9 class-ID: 0403
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-2:2 chip-ID: 046d:081b class-ID: 0102 serial: 23CC4900
  Device-4: TerraTec GmbH Aureon Dual USB type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 6-1:2 chip-ID: 0ccd:0077
    class-ID: 0300
  Sound Server-1: ALSA v: k5.19.0-32-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: NVIDIA MCP77 Ethernet vendor: ASRock K10N78FullHD-hSLI R3.0
    driver: forcedeth v: kernel port: 9880 bus-ID: 00:0a.0 chip-ID: 10de:0760
    class-ID: 0200
  IF: enp0s10 state: down mac: 00:19:66:95:bb:3a
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: TP-LINK TG-3468 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e800 bus-ID: 04:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: 50:3e:aa:0d:94:6e
  Message: No RAID data found.
  Local Storage: total: 4.32 TiB used: 450.47 GiB (10.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: S2RBNXAH108619N rev: 2B6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: Z4Z1QG3Y rev: CC25 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST31000528AS
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: 9VP9W7X3 rev: CC38 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Crucial model: CT250MX500SSD1
    size: 232.89 GiB block-size: physical: 4096 B logical: 512 B
    speed: 3.0 Gb/s type: SSD serial: 2143E5DBAF7B rev: 043 scheme: MBR
  ID-5: /dev/sde maj-min: 8:64 vendor: Crucial model: CT1000BX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: 2205E6065CFA rev: 060 scheme: MBR
  ID-1: / raw-size: 50.3 GiB size: 49.21 GiB (97.83%) used: 14.97 GiB (30.4%)
    fs: ext4 dev: /dev/sde2 maj-min: 8:66
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.45 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda1 maj-min: 8:1
  System Temperatures: cpu: 36.0 C mobo: N/A gpu: nouveau temp: 38.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0
  Processes: 218 Uptime: 50m wakeups: 2442 Memory: 7.27 GiB
  used: 1.66 GiB (22.9%) Init: systemd v: 249 runlevel: 5 tool: systemctl
  Compilers: gcc: 11.4.0 alt: 11/12 Packages: 2074 apt: 2063 lib: 1072
  snap: 11 Shell: Bash v: 5.1.16 running-in: tilix inxi: 3.3.13

This morning I updated the operating system. to the latest kernel (6.5.0-14) which corrupted my nvidia drivers, as listed below:

Processing errors occurred:
E: Sub-process /usr/bin/dpkg returned an error code

as well as inhibiting the operation of the various launchers on the dock at the bottom

while the s.o. starts regularly with kernel6.2.0-39.
the question: how can I delete the latest kernel? and if so, how?
thanks for your support

I’m aware that there are a few issues encounted with the new 6.5 HWE kernel that Canonical have just pushed out. Mainly around virtualbox not working correctly.

I’m not aware of nvidia issues to-date.

Since this a HWE kernel you can’t “delete” it as such - it will just come back. You need to remove the HWE itself and go back to kernel 5.19 which is the standard kernel.

But first things first - please do report this on launchpad. Without this, Canonical cannot assess and provide a real fix.

In a terminal run

ubuntu-bug linux

Fill in the bug report - make sure you copy-paste any terminal errors such as what you have said above - it needs to be the full error which you probably will get if you run

 sudo apt update && sudo apt full-upgrade

Thanks for your suggestion.
I solved it, at least for now, by installing synaptic and deleting the 6.5.0-14 kernel, including hwe.
so I did an update-grub and everything works with the previous kernel.
Today the notice of available updates appeared, among which there was no kernel 6.5.0-14 and which I installed regularly.
On synaptic there is kernel 6.5.0-14 but it is not enabled.
Do you think that by leaving things as they are it won’t happen that an update can install the latest offending kernel?

I tried to run the command ubuntu-bug linux from the terminal, but it gives me the following response:
It is not possible to report the problem