[Solved] - Budgie 22.04 - files manager icon disappeared

these are my quickinfo:

apanta@apanta-desktop:~$ inxi -FZA
  Host: apanta-desktop Kernel: 5.19.0-32-generic x86_64 bits: 64
    Desktop: Budgie 10.6.1 Distro: Ubuntu 22.04.3 LTS (Jammy Jellyfish)
  Type: Desktop Mobo: ASRock model: K10N78FullHD-hSLI..
    serial: <superuser required> BIOS: American Megatrends v: P2.30
    date: 04/30/2010
  Info: dual core model: AMD Athlon 64 X2 5200+ bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 1000 min/max: 1000/2700 cores: 1: 1000 2: 1000
  Device-1: NVIDIA C77 [GeForce 8200] driver: N/A
  Device-2: NVIDIA GF106 [GeForce GTS 450] driver: nvidia v: 390.157
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: nvidia
    gpu: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTS 450/PCIe/SSE2 v: 4.6.0 NVIDIA 390.157
  Device-1: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
    driver: snd_hda_intel
  Device-2: NVIDIA GF106 High Definition Audio driver: snd_hda_intel
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Device-4: TerraTec GmbH Aureon Dual USB type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.19.0-32-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: NVIDIA MCP77 Ethernet driver: forcedeth
  IF: enp0s10 state: down mac: 00:19:66:95:bb:3a
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: 50:3e:aa:0d:94:6e
  Local Storage: total: 4.32 TiB used: 472.28 GiB (10.7%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB
  ID-3: /dev/sdc vendor: Seagate model: ST31000528AS size: 931.51 GiB
  ID-4: /dev/sdd vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB
  ID-5: /dev/sde vendor: Crucial model: CT1000BX500SSD1 size: 931.51 GiB
  ID-1: / size: 49.21 GiB used: 11.82 GiB (24.0%) fs: ext4 dev: /dev/sde2
  Alert: No swap data was found.
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 35 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 207 Uptime: 18m Memory: 7.27 GiB used: 1.76 GiB (24.3%)
  Shell: Bash inxi: 3.3.13

today after the start of the s.o. I noticed that the file management icon, normally present in the dash, has disappeared.
I haven’t found how to reinsert it and by launching plank preferences the aplet is not among those available.
Can you tell me how to solve this problem?

From the menu just search for “nemo” and run the app.

The icon will appear in plank (if that is what you are using) or the icon-task-list.

Right click and “keep in dock” for plank or click the Star symbol for the icon-task-list

Thanks for the reply.
I tried typing nemo from the menu but it can’t be activated
Thanks for the reply. I tried typing nemo from the menu but it can’t be activated. I tried reinstalling nemo <sudo apt install -reinstall nemo>, but I didn’t solve it.
I tried with <sudo apt install -f> but it didn’t solve it.
If I click on the home icon (apanta) from places I get:
I am therefore stuck not knowing how to proceed.
I finally tried to create a new user.
When I log in, the icon appears in the dock, but it is not active.

If you type nemo in a terminal what do you see?

Continuing with the user created during installation,
if I type nemo in the search window, it appears: sorry, no items found.
I also changed the theme via Budgie Remakes & Layout but the icon still doesn’t appear.

apanta@apanta-desktop:~$ nemo
Command «nemo» not found, but can be installed with:
sudo apt install nemo
apanta@apanta-desktop:~$ sudo apt install nemo
[sudo] apanta password:
Reading package list... Done
Generating dependency tree... Done
Reading status information... Done
Some packages cannot be installed. This may mean that an impossible situation has been requested or, if you are using a distribution under development, which requires some packages
have not yet been created or have been removed from Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  xapp : Depends: libxapp1 (= 2.2.8-1) but version 2.8.1+klbkjammy is about to be installed
E: Unable to fix problems, there are corrupted packages blocked.

I looked for libxapp1 on synaptic and reinstalled it.
the result is always the same.

This is the danger of adding PPAs without studying what they contain and possible implications.

You appear to have added this PPA

This uplifted a critical package nemo required. The package manager tried to resolve this by uninstalling nemo.

My recommendation here is to purge that ppa to allow nemo to be installed

sudo ppa-purge ppa:kelebek333/mint-tools
sudo apt update
sudo apt installed nemo

Removed the ppa as per your instructions and reinstalled nemo from the terminal.
It seems to be working fine now.

I wrote nemo in the search window and then, once the home window opened and the icon appeared on the dock, I enabled with the right button: keep in dock.

Thank you for your patient support. :+1: :innocent: