Home Store Blog Development

VirtualBox shared clipboard not working on Budgie 18.04


#1

Ubuntu 18.04 (Gnome) works OK. LXQt 18.10 works OK. Budgie 18.04 not working OK. So, I am assuming it could be specific to Budgie. Any hints what to check?


#2

seems to be working fine here.

Using virtualbox 5.2.8 installed from the virtualbox website. Have installed the 5.2.8 virtualbox guest additions - again from virtualbox themselves.

Made sure I was in the vboxsf account in the guest and that in the virtualbox menu - Devices - Shared Clipboard - bidirectional was ticked.


#3

Always worked well for me too. ( Linux, Debian, WIndows guests)…
Version 5.2.12 r122591 (Qt5.9.5)

Make sure your installed Guest Additions and also follow fossfreedom advices
https://www.virtualbox.org/wiki/Downloads

I don’t think it is necessary but " VirtualBox 5.2.12 Oracle VM VirtualBox Extension Pack " add more functionalities but not required for Copy / PASTE


#4

Must be getting old :slight_smile:. I assumed that I have installed guest additions as I can resize the window. Anyway, after installing GA copy/paste works! Thanks all for the reminder.


#5

Had the same issue and yes, the installation of the Guest Additions solved the problem. Forgot to install it this time with this as a consequence (why is the guest additions not installed implicitely or, like the extension pack, you’re asked to do it?).
All resolved now, can traditionally start copy/paste again!


#6

Guest additions is NOT opensource - so cannot be shipped by Ubuntu. That’s an oracle decision.

The Guest additions is “free” for personal use … but as soon as you use it in business you have to pay oracle - that’s described in the EULA you read when installing the guest additions.