19.10 Beta - QuickNote queries

The right-click menu is white-on-white. Copy ^C followed by [del] before pasting it elsewhere deletes the copied text!

Screenshot? What theme are you using?

Pressing del would delete text. Sounds normal

If I run the pointer up and down the menu, some options appear and

  1. Screenshot?
    Can’t be done as focus (or whatever it’s called) shifts to screenshot
    program, so right-click menu disappears from QuickNote. However, see photo of screen in next message.

  2. What theme are you using?
    With Widgets as “Arc” it still does it.

  3. Pressing del would delete text. Sounds normal

Better explained: If I select text then press ^C it should be in the
paste-buffer (or whatever it’s called). If I then press [DEL] it will
delete the selected text. However I would not expect it to be deleted
from the paste-buffer, so I should still be able press ^V to paste it
elsewhere. I can’t, it’s gone - perhaps only the first time after
logging in?

Try adding a time delay to the screen shot then open the applet.

The context menu included with the Quick Note applet doesn’t function at all on my installation. The icon flickers when closing as well.

Doubtful a context menu makes sense for a popover. I would expect weird things to occur if you popup a menu on a object that is already in a popup scenario.

Sounds like the bug is that the context menu should be disabled.

@ChrisOfBristol I tried to find anything incorrect in how things work, but all seems fine.
Let’s look at how things should work:

  • Right click -> Delete - selected (deleted) text should not be copied to clipboard.
  • Right click -> Cut - selected text should be copied to clipboard, deleted from original place.
  • Right click -> Copy, then right click, Delete - same as above, but Delete is redundant.

That is pretty much exactly how things do work correctly.

The applet works properly on the desktop computer with Nvidia and doesn’t on the laptop with intelScreenshot%20from%202019-10-02%2009-09-28 graphics .

what doesn’t work on intel?

BTW - going to throw an update to disable the popup menu. right click popup context menu on a popup applet where budgie deliberately does not try to have right click “non discoverable stuff” doesn’t really make sense.

On the intel graphics the icon flickers and the context menu options appear , but don’t function. HP8460p, i5, cpu 3.2 Ghz ,4Gb ram intel integrated graphics .

k - disabling the context menu makes even more sense then.

4 posts were merged into an existing topic: 19.10 from beta to release

ok - update is now available - context menu has been disabled.

@vlijm I can’t reproduce the copying error.

@fossfreedom Context menu has gone.

Rapid fix - thanks!