Adobe Flash Plugin 101

So what’s the deal with Adobe Flash. I need it for YouTube-TV. Do I install it into the system, into Chromium, or install Google Chrome?

Open Tilix terminal and login as superuser.
a) sudo su
b) apt install adobe-flashplugin

Chromium webbrowser is a good choice instead of using Google Chrome anyway.
I prefer the Firefox browser : Make your Mozilla Firefox webbrowser faster, safer, more stable


Hm. I did it again and it say it’s already installed with the latest version.
On 17.08. was a update to version
Has it not a way to switch from Flash to HTML5 in YT-TV?

You need to have « Canonical partners » repository enabled in your sources.
You can check that in Synaptic → Settings → Repositories → « other softwares » tab.

Don’t use any other method to install flashplayer. Only that one from « official » repository : it will stay up-to-date like any other piece of your system, through regular automatic update mechanism.

If you did use other method(s) to install flashplayer, first make sure to delete any remaining elements of those.


I had to install Synaptic. In repositories I saw two things to check but only checked the first one.


“Don’t use any other method to install flashplayer.”

I was confused but concluded you were referring to Hafenzol’s method.

It still doesn’t work. I’ll attempt to reboot.

Now that the right, safe repository is enabled, you can install adobe-flashplugin either by :

  • command line sudo apt install adobe-flashplugin
  • searching in synaptic for adobe-flashplugin and right-click install

Other methods I referred to were « older » ones, less safe or less easy to keep up-to-date, so no need to worry about these :wink:

1 Like

Thanks for all your help. Regrettably it still doesn’t work.

I go to Adobe Test page. It tells me to enable Flash. But it doesn’t enable for YouTubeTV or even the test page.

I’m going to take a break in Windows 10. :wink:

Mmm… would you mind :

dpkg -l | grep ado

( copy/paste in terminal, it’s a little L not a 1 )

If it’s installed it should answer :

you@machine:~$ dpkg -l | grep ado
ii  adobe-flash-properties-gtk                 1:20180814.1-0ubuntu0.18.04.2               amd64        GTK+ control panel for Adobe Flash Player plugin
ii  adobe-flashplugin                          1:20180814.1-0ubuntu0.18.04.2               amd64        Adobe Flash Player plugin

Do you use a « regular » apt/deb version of Firefox or a snap-version of it ?

snap list

I don’t know Youtube-TV but youtube itself does no longer require flash to work, for a couple of years…

Be aware flash is a near-death technology, supposed to die in 2020.

So very helpful, Coeur-Noir

This is what I got


I had de-Snaped a Firefox on a different PC, but not this one.

Now I am de-Snapped. Still doesn’t work. Two theories –

  1. Linux is the problem
  2. Chromium is the problem

I can sudo apt get Chrome itself, yes? I don’t want to break anything.

google-chrome is a problem : it’s proprietary software, and uses your personal datas and secrets to make money. So I won’t explain how to install it.

Let’s try this, delete the following hidden folders and files from your /home/<you_user> :

 ~/.config/chromium/Default/Pepper Data/Shockwave Flash

Then reinstall adobe-flashplugin.
sudo apt install --reinstall adobe-flashplugin

Also remember, as it’s a dying technology, most browsers won’t automatically launch flashplugin on the needed webpages, you’ll have to confirm that choice, most of the time at the left of the address bar.
And yes, even on the Adode test web page, so be quick !

Does youtube-tv make use of any DRM for content protection ? If so you also have to enable DRM in Firefox, it’s not enabled by default under Linux for ethical reasons.

[edit] ouch… if you need DRM enabled browser, you’ll probably end up with installing google-chrome anyway, so have a look at for example, or in french :wink:

Pretty brutal, right?

I’ll check this out tomorrow

Errr… me ? I did not mean to sound brutal, sorry, English is not my native language.

Non, mon ami français. La procédure pour corriger Flash est brutale.

Lol. Yes, that’s what flash needs !

More seriously it’s just a way to « reset » flash settings, sometimes it helps.

But in your situation I think it’s more about CDM & DRM.

No great success now?
Try to figure out by

“You need to have « Canonical partners » repository enabled in your sources …”

It’s implemented in the main repository since two years - at least after version 11.x
Did you done a “apt update” before?

As far as I can understand, adobe-flashplugin is not in the main repository. I think it can’t be there for legal reasons.

It’s rather flashplugin-downloader which is one of the many avoidable methods regarding flashplayer

The adobe-flashplugin package provides both the NPAPI and PPAPI plug-ins, i.e. it provides Flash for both Firefox and Chromium like web browsers.

  1. Make sure that the Canonical Partner repository is activated.

  2. Install the adobe-flashplugin package.

  3. Restart your browser.

1 Like