Another Update...And Another No Boot Situation

Just did my normal update when reminded by the system this evening. 22.04. Now my workstation won’t boot normally. I can get it to boot into generic recovery mode, but that’s it. Here are some photos of the messages I’m getting on boot up, and when trying to repair things in recovery mode. Apologies for the poor quality. I do not have the unix chops to interpret these messages, so any help is welcome.

The screenshots are complaining about the sdb disk. Is this your install disk or have you a partition such as the home partition there?

The ata errors is the disk controller.

All in all it looks like a very poorly disk is the issue.

1 Like

Thanks fossfreedom, that makes sense. Just seems odd it would happen with an update. I’m running some tests with the Disks utility, and so far they check as OK. I’ve attached a couple of pics with the output from sudo lshw -C disk and the Disk self test of /dev/sdb. It checks OK, as do all the others. Any thoughts?

Hmm… well Canonical released a new kernel for 22.04 on the 1st December… wonder its buggy for your drive?

Boot from an earlier kernel via grub

I have a similar problem except that when it gets to the login window it freezes up completely. Keyboard and trackpad unresponsive. Can’t login…

The budgie symbol briefly flashes on screen on boot which has never happened before.

I am locked out-please help!

Here’s a little more info on my system:

  • Boot drive is a Samsung SSD 960 EVO. /dev/nvme0n1. I see no problems with this at the moment.
  • 1 TB Seagate Barracuda. /dev/sda. I can mount and view this one. Short test OK.
  • 1 TB Seagate Barracuda. /dev/sdb. I cannot mount this disk, unknown error. Disks utility short test says OK, extended test says OK.
  • 0.5 GB Westerd Digital. /dev/sdc. Running normally.
  • various virtual disks

Gparted was not able to load /dev/sdb. “Libparted Error - could not stat device”. Seems odd that Disks says it is OK.

I’m going to disconnect the /dev/sdb disk and see if that allows me to boot normally. Then try to recover data. Right now a normal boot is the priority.

@fossfreedom - I recently rolled back from 5.17 to 5.15 as 5.17 was causing issues. I’m going to stick with 5.15 for the moment.

As I mentioned try the earlier kernel via your grub screen … remember to press and hold shift immediately after turning on to display your grub if its not already displayed during boot.


I’ll give it a go! Reckon you are right that it’s a problem with the last software update. Buggy as hell…

I unhooked both of the Seagate Barracuda drives. All the offending messages about ata4 and /dev/sdb are gone. But still no boot. This is what I see:

/dev/nvme0n1p2: clean, 821094/30498816 files, 17643203/121965056 blocks

Going back into recovery mode…

@fossfreedom - In grub, I only have one choice of kernel: 5.15. There are normal, low latency and recovery mode options. But no other kernels. I’ll check grub and see if I have another turned off; but if I do, it will only bring up 5.15 and 5.17 I’m guessing.

I have found that the previous kernel works many thanks.

Can you please tell me how I can set it to boot from that kernel automatically rather than having to select it manually every time.

I used fwupdmgr to check for the latest firmware for my boot drive Samsung 960 EVO - it was running the latest firmware. Contemplating options here…thinking about installing an older kernel, but this pc has been running on 5.15 with no problems for a long time now.

Also creating a boot usb to attempt a boot repair.

@The_Machine_101 - you need to edit your grub file, google it, lots of instruction on how to do this.

I’m doing that - it’s not easy! I’m a newbie here! Thank you.

OK, Houston, we have liftoff. Created a live boot usb drive, booted, installed boot repair, ran the repair, and booted up normally. Whew! Feel like I dodged a bullet here. Now on to find which of the Seagates is the offending disk, and try to recover the data. Aren’t computers fun? :crazy_face:

1 Like
1 Like

Many thanks buddy. :handshake:

1 Like

I have followed the instructions but every time I change the grub default value save it the window freezes & I have to hit esc to close it.

I have ran the update grub command but the default value goes back to 0.

It’s just not working…

I have finally worked it out (with much effort!) and am back in business. :slightly_smiling_face:

Many thanks again for your help.