AppIndicator Applet broken on 22.04?

Does not appear like the applet works any more :/?

working here. Just tried a brand new install.

Then installed diodon and ran diodon from the command line. The clipboard manager was instantly visible in the appindicator

Hmmm… odd, well I am not seeing my Kinto.sh app showing up on the AppIndicator any more. I may need to install other apps that use it to confirm how bugged it may be for me. I am just now getting around to running 22.04 on anything (just running it inside a VM atm).

Maybe it is something my Sorun.me script did wrong for 22.04. I haven’t yet stepped through it carefully to make sure it is not adding anything that is incompatible.

Is this a python appindicator?

You’ll need to ensure gir1.2-ayatanaappindicator3-0.1 is installed and your appindicator should have something like this indicator-sysmonitor/indicator-sysmonitor at 6a4e9f432dc99a8c5e5a0a8c41954684d6df0469 · fossfreedom/indicator-sysmonitor · GitHub

That package appears to be there, but looks like this is the error message I get. I’ve not yet googled the solution, but I will in a bit.

./kintotray.py
Traceback (most recent call last):
  File "/home/rreaves/.config/kinto/./kintotray.py", line 6, in <module>
    gi.require_version('AppIndicator3', '0.1')
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 126, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace AppIndicator3 not available

look closely at the error message and the link I gave you - UB now uses ayatanaindicators - so you need to import the correct library

Ah, that makes sense, guess I will need to find out the proper name for the new package in python.

try:
    gi.require_version('AyatanaAppIndicator3', '0.1')
    from gi.repository import AyatanaAppIndicator3 as appindicator
except ValueError:
    gi.require_version('AppIndicator3', '0.1')
    from gi.repository import AppIndicator3 as appindicator
1 Like

Updated Kinto to support Ayatana indicators. Thanks for the help!

1 Like

Hello, I face the same issue, but probably for a different reason.
I recently upgraded from Ubuntu Budgie 20.04

Although I have ensured the AppIndicator applet is on my panel, enabling diodon, nextcloud or skype won’t show any new icon there.

So far I have checked that budgie-indicator-applet, libappindicator-dev and the perl extension Gtk2::AppIndicator are all installed (not sure if the last two are relevant).

Do you know if there are any logs I can check or if there is any common reason for this issue?

Thanks a lot

The dev package is only needed if you are changing code. Are you? Have you manually compiled stuff?

What indicator packages do you have installed

apt purge indicator- ... and press the tab key... eventually the list of indicator packages installed are listed

Ctrl + X to exit

Next list the ayatana packages installed

apt purge ayatana- ... and press the tab key like above

Ctrl + X to exit

Thanks a lot @fossfreedom for your answer,
I have the indicator-application and indicator-common packages installed.

Similarly, the ayatana packages installed are: ayatana-indicator-application and ayatana-indicator-common

that looks ok.

ok - one further diagnostic on my machine:

ps -ef | grep indicator
dad       244182  243681  0 10:38 ?        00:00:00 /usr/libexec/ayatana-indicator-application/ayatana-indicator-application-service
dad       244196  243681  0 10:38 ?        00:00:00 /usr/libexec/ayatana-indicator-printers/ayatana-indicator-printers-service

What do you see when you run the ps command? the key line that must be running is /usr/libexec/ayatana-indicator-application/ayatana-indicator-application-service

Bellow is my output.
The process you mention is running.

angelos     2191    1722  0 09:32 ?        00:00:00 /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service
angelos     2195    1722  0 09:32 ?        00:00:02 nm-applet --no-indicator
angelos     2217    1722  0 09:32 ?        00:00:00 /usr/libexec/ayatana-indicator-application/ayatana-indicator-application-service

Thats the key culprit - it shouldnt be running - purge “indicator-application” and “indicator-common” packages, logout and login.

1 Like

Perfect, it’s fixed!
Thanks a lot for your help @fossfreedom!

I ran into the same problem today (coming from Ubuntu Budgie 21.10) and @fossfreedom’s advice that solved it for @angelo_ml worked for me as well. Thx! :+1:

sudo apt purge indicator-application indicator-common

sorry, I just realized I was not doing what you said higher correctly, and deleted my post because, once I realized that, I was able to make it happen.
All is well now.
Thanks for your help.