Home Store Blog Development

Auto Login not working


#1

I’m struggeling to activate autologin in Ubuntu Budgie 18.10. I can activate it in user settings but after reboot the setting is reverted back to deactiveted.


#2

Choose Menu - Login Window and click on the Users tab.

At the bottom enter into the field the name of the account you want to login as - tab away to save automatically and reboot.


#3

User name was allready listed in Login Window/Users Tab as Autologin. Deleted it and tried again, no effect.
It seems there are two places where this can be defined:

  1. Login Window -> users tab (setting remains after reboot)
  2. Settings/information/user (setting reverts after reboot)
    I have no effect changing the one or the other or both. Still requests password after reboot.

Update,
I realised that the setting in Login Window will keep my username in autostart even when I deleted it. This happens after restarting of the app.

Is there a config file to maintain the autologin manually? Setting is actually in etc/lightdm/lightdm.conf but I would have expected in etc/lightdm/users.conf.


#4

Not sure what is happening with your setup

I can add my login name to “Login Window” and it will autostart without any issues

If I then go in and delete my name, “Login Window” removes the name and autostart is disabled.

/etc/lightdm/lightdm.conf is updated by “Login Window”


#5

I did a fresh install the other day. Setup is unchanged.
Any idea if the access rights to the conf file needs to be changed/corrected?


#6

This is my setup


#7

This is my setup:


#8

And what happens if you replace the contents to what is my setup (obviously change the user name to dominik!) ?


#9

changed it accordingly, no change :frowning:


#10

hmm… sorry - no idea :frowning: