No gui login screen

so the GUI for the login window is not working and when I tried to log in as ubuntu it didn’t work and neither did reinstall lightdm
plz help

(also I would add screenshots but I’m new here and don’t know if they are allowed )

They are.
As you are «new » you can directly post only one picture, by drag and drop your file onto your message.

You may also use pictures hosting services like imgbb, postimage and the likes.

cool thank you also this is what i get basically:

Please can you explain what you did before this started happening?

Were you installing/removing any applications? If so what exactly were you doing?

It’s a console.

Here you can login by typing your user’s name, enter, then your password ( which will stay hidden ), enter.

Now you could issue commands.

But yes, before suggesting you some commands, you should give us bits of context :wink:

We might help. We might not guess what you did and what you saw.

before i was trying to find how update the Intel graphics to no avail then the next day i got the console login window and tried to uninstall and install lightdm and got errors IMG_5480

sudo dpkg-reconfigure lightdm

might do the trick.

While there you should check for updates :

sudo apt update ; sudo apt full-upgrade ; sudo apt install -f ; sudo apt autoremove --purge

Meaning in sequence : check for updates, install what can be, check for eventually missing dependencies and remove obsolete and unused things.

it did not work and I forgot the upgrade line

So when I tried auto remover —purge It said that it was not understood

Its not so clear what has transpired to get yourself into this situation.
Firstly, is this a new install of Budgie?
If yes, then another shot at installing wont hurt. I see you have a Lenovo and would suggest you do a search here as some of us have similar Lappy and have had some install issues usually to do with BIOS setup problems.
Regards, Al.

It does sound like you have unintentionally removed much more than you have realised.

I would put this down to a learning experience.

Reinstall from scratch is the easiest way here. Boot to a live usb session. Backup what you need onto another usb external drive before installing.

Well it’s not

sudo apt autoremove --purge

Nevermind. Reinstalling might solve faster your issue than trying to narrow down what’s gone wrong.
Ideally when issuing commands, helpers here expect you to post their outputs. Which is obviously less handy from console.

honestly there wasn’t any thin really worth saving and i have another computer that i use alot more so i just installed 20.04 and try to learn more about how to use linux to avoid/ solve these problems
also how do you remove the time and date from the desktop

Budgie Settings -> applets, remove showtime