Very happy but double login screen

I’m really excited about my new budgie (and ubuntu) which allows me to see my google-drive account in 1 second without any further application.
Budgie is much more beautiful and functional than classic ubuntu. Because my login page shows me a low resolution screen first, I enter my password, and immediately afterwards it shows me a new login form, at optimal resolution (which is the same resolution I will see after making this new login )?

how odd - can you take a couple of photos (with your phone for example) showing the two screens?

Just want to clarify what you are seeing.

What screen resolution are you using?

What version of Ubuntu Budgie are you using?

now my screen resolution is 1920x1080 (16:9)
ubuntu 19.04


very interesting. Haven’t seen this before.

Please can you open a terminal at copy paste the following:

journalctl --since today > output.txt

This will create a file of everything that has happened today - need to understand what is happening between the two logins. Please you upload the file here (I think) - or use if text files are not allowed to be uploaded - paste the url here.

Also what is the output of the following?

dpkg --list lightdm* *greeter* | grep "^ii"

emigio@remigio-Veriton-X270:~$ dpkg --list lightdm* greeter | grep “^ii”
ii lightdm 1.28.0-0ubuntu1 amd64 Display Manager
ii lightdm-settings 1.1.4-0ubuntu1 all LightDM Settings Configuration Tool
ii slick-greeter 1.2.4-2ubuntu1 amd64 Slick-looking LightDM greeter

interesting. There appears to be a crash due to your nvidia driver.

If you switch back to the opensource nouveau driver does everything work correctly?

Is the nvidia driver you are using the recommended driver from Hardware Drivers?

Also I’m wondering what happens if you connect via VGA cable rather than HDMI (or visa versa) ?

switch back to the opensource nouveau driver–> issue doesn’t happens (but video on youtube is not very fluid)
Is the nvidia driver you are using the recommended driver from Hardware Drivers?–> YES

Sorry but now I don’t have a VGA cable

Ok - as I thought - its an nvidia issue. By its very nature, there isn’t anything anyone can do here because it is proprietary (not opensource).

The best advice I can suggest is to look at what options you have for connecting your monitor - try VGA or DVI if you have those ports. You will need to obviously buy a cable to-do that.

Additionally/alternatively you can experiment further with a later version of the nvidia driver e.g. v430 if your nvidia graphics card supports that

I would strongly suggest you first make a full disk image backup (e.g. using clonezilla) onto an external USB drive just in-case installing the upgrades leaves you with back-screens or worse that cannot be recovered from.

Just tried with vga cable and:
vga cable+opensource driver–>OK
vga cable+nvidia driver–>OK
hdmi cable +nvidia drive–> now it’s OK
so I deduce that it is enough to make a switch between open and original drivers, and the problem has disappeared.

1 Like

I don’t know if it is related to the video card driver problem, but when I wake up from the suspension I always have this desktop page (see attached image)

Its a known issue by the GNOME mutter developers. It has been fixed in 19.10

It has been proposed to be fixed upstream for 19.04 - it hasn’t been accepted as yet.

It hasn’t been backported to 18.04 - since 19.04 needs to have the fixed applied first.

same issue on 19.10

try testing on the 20.04 beta if possible