AUTO-LOGIN not working with any Budgie i have tested

I have this auto login problem with any Budgie desktop. I mean, i have tested Ubuntu Budgie, solus budgie and manjaro budgie, all with the same results. You see, i configure the auto-login from the installer and it asks for a password at every login (loaded desktop) anyway. I configure auto login from the gnome control center too and again, the next start it asks for a password. I don’t know if this is a budgie, lightdm or gnome bug but i have no solution. Any idea?

On UB I have set autologin via the Menu - Login window. Have you tried that?

Do you mean the gnome user configuration panel? I do that but next time it appears as auto login off again.

No. There is a menu option called Login Window.

This assumes you have lightdm-settings installed on your computer which is part of the default install of UB

Lightdm-settigs: auto login user active. Really strange bug as you can see.

Please describe your installation… what options and configurable stuff did you choose?
I cannot reproduce your issue … I normally just click next next next through the installer to install the defaults.

This is what i do:
1- install alongside windows (one swap and one root ext4 parition.)
2- Choose minimal install
3- Install updates while installing
4- Auto login: ON.
Auto login works first time, next time it will go directly to desktop and asks for admin password.
By this time i go to the gnome control center and choose users-unblock and activate auto login. At next start asks for admin again, then i go to gnome control panel and it appears off again.
If you go to lightdm settings it appears my username as if it was auto login active.
The only problem i see is the gnome user control panel going off again and again every start.
Curiosly, when i tested manjaro budgie and solus budgie i had the same problem. Came to my mind a shared bug of gnome or ligthdm, but in that ocassion seahorse was asking for the admin password because it was not unblocked during desktop start. Maybe seahorse bug? I don’t see seahorse on UB. What is used to manage keys?

Ah wait… you are not referring to desktop automatic logins.

You are talking about the gnome keyring dialog.

Have a look here as to why that dialog appears

Thanks, that did the trick.
Seahorse was not installed, but how does UB manage keys without it? or maybe it is a “minimum install” problem during instalation?

Seahorse isn’t part of our install. Usually you dont need a key manager because stuff like lightdm will normally interact seamlessly with gnome-keyring. In this case you are using autologin, and it bypassed the interaction with gnome-keyring.