Auto Login Turns Off After Reboot - 22.04

Brand new PC - literally assembled earlier this evening.

  • AMD Ryzen 5 5600G
  • MSI PRO B550M-VC WiFi
  • NVMe M.2 SSD
  • Ubuntu Budgue 22.04

I had zero issues installing the OS, normal install, default partitioning. Once logged in, I open the “Users” app, unlock my user, allow auto login, and reboot. Every time the machine restarts, I’m forced to login again. Under the “Login Window” app, under users, my name is also set to allow auto login.

I’m not sure what I’m missing. I’m running the same version on two other machines (one Dell AIO, and a Dell laptop), and have no issues at all. Auto login works like it should. Any ideas?

can I confirm you are running slick-greeter with the new PC and not some other greeter? Or have you installed - for example - GDM3 or another login manager?

If that is the default login manager, then yes. I made no changes to the system.

  • Installed Ubuntu Budgie 22.04 - Normal install, default configuration, no encryption.
  • Logged into the system for the first time.
  • Launched “Users”, unlocked my user, enabled auto login.
  • Rebooted & was prompted to sign in again.
  • Set my user for auto login again.
  • Launched “Login Window”, verified my user was set to allow auto login.
  • Rebooted & was prompted to sign in again.
  • Repeated the above steps, installed “Seahorse” and tried blanking and then deleting login keyring.
  • Rebooted & was prompted to sign in again.

Those are the only changes I made to the system.

can I ask a silly question - is it the actual greeter login prompt of is it the keyring login prompt message you are seeing? i.e. are you at the actual desktop or are you seeing the login manager “purple” with offset list of users screen?

Not a silly question, I’ve seen that mistake made before. It is the actual greeter login prompt; the prompt, offset to the left side, my username with the password field.

Once I was signed in, I tried the keyring route just to see if it made any difference.

not something I have seen. I am wondering - is the name you are trying to autologin with a standard ascii name - or something with some “special” characters? Just wondering if you have hit a strange slick-greeter / lightdm bug

Standard ascii - just my first name, all lower-case. ‘justin’

lets try something - create a brand new user called “abc”, login with that user to initialise everything and then set that account to be the autologin account in login manager

I have tried that, and it made no different. The new user acts the same. However, I only set the auto login flag in the “Users” screen. I did not verify the settings in the “Login Window” app.

I’m at work now for the day, but will try again as soon as I get home this afternoon and report back. Any additional information that might be useful? Meaning, is there anything more I can provide about my system.

Edited for clarification.

yeah - I’m interested in just using the “login window” to set autologin and seeing if that resolves matter - thats the tool the slick-greeter team has provided - I’ve never tried with the users screen.

10-4. I will report back later today.

Well, success, but not via the suggested action. Since the PC is new, I went ahead and installed 22.10, and I no longer have the issue. Auto login and all hardware appears to be working as it should, and it’s lightning quick. I do get a few “blacklist hash” errors on boot, but a quick search of that pulls up countless other instances of that, so I’m not too concerned there.

No idea what was going on with 22.04, but I’m perfectly content on 22.10 at the moment.

Hmm… i will keep an eye out for similar reports on 22.04 to see if there are any patterns to the issue. Yours is obviously the first!

I have exactly the same problem with 22.04 fresh install