Bizarre behaviour 18.10 - nm-applet and bluetooth etc

I am currently testing 18.10 of Budgie, and weird stuff is happening… Wifi is actually DISABLING itself (and Bluetooth as well)… of course nm-applet completely disappears, so it may be linked to networking daemon/service???

Also, my Notifications icon is turning blue for no reason… it resets to white after clicking on it twice (usually) :-/

Anyone else see this kind of behaviour? ps. I am using Gigabyte H370 HD3 + i7-8700 + RX 580 + 16GB DDR4 2666 RAM + nvme SSDs + Samsung 850 Evo (Budgie) + 2 x 4TB storage HDD.

Hi and welcome,

sounds like the 4.18 kernel isn’t playing nice with your setup.

Since you are in testing mode, it is worth testing 19.04 which is due in a couple of days time - it comes with kernel v5.

Notifications turning blue is normal when there is a notification - click on the icon and raven (the side bar) will open to list the notifications.

Except there are never any notifications :frowning:

Can I do a dist-upgrade to 19.04?

I would be interested to know HOW the OS manages to disable the hardware for WiFI and Bluetooth simultaneously?

That’s the kernel itself I’m guessing.


journalctl -ae --full

and scrolling back should give you an idea of what is happening


nm-applet[2165]: Can’t set a parent on widget which has a parent


kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)

there are LOTS of the Bluetooth errors, only a few of the nm-applet errors…

hmmmm, and…

bluetoothd[1130]: Failed to set mode: Blocked through rfkill (0x12)
budgie-panel[2072]: Error setting property ‘Powered’ on interface org.bluez.Adapter1: GDBus.Error:org.bluez.Error.Blocked: Blocked through rfkill (g-io-error-quark, 36)

It seems to be going OK this sessions, I disabled the two power options which allow devices to be switched off to save power (under Power settings) !!!

Save power on a desktop system?

Think I found the issue… setting the two power saving options ACTUALLY DISABLES both devices :expressionless:


Also the other options change from Never to 0 seconds… which is OK if it actually works.

Thanks for your help… I’ll see how long this works

Well found!

Dont know why though that those two options are enabled though … did you accidentally set then as enabled?

They were showing as ENABLED, I tried to DISABLE the setting, but it disabled the HARDWARE :frowning:

It simultaneously kills the hardware and nm-applet :-1:

This is the longest session I have had without the nm-applet dying, I may have solved it accidentally :blush:

I’m going to use Budgie for one more session… and if it doesn’t happen again, I’ll mark this thread as SOLVED. Cheers.

NO, it happened yet again… and again… so I am deleting Budgie and never trying it again… it’s bad enough having all my controls on my 4K monitor the size of a grain of rice… but WiFi (BCM94360CS) was nigh on unusable, and prone to spontaneous disconnection. I might try Linux (an older version not using Wayland) on some older hardware… but not like this.

As I mentioned previously 19.04 has the latest kernel. It also has experimental fractional scaling support.

Anyway. Best wishes