Home Store Blog Development

Wifi icon gone rogue: 18.04


#1

Hi folks. Booting twice on my test 18.04 install my wifi icon has a black background and behaves separately from the rest of the bar. If the top panel auto-hides, the wifi icon will still be there. Too tired to screencap and upload it now, just FYI. If it persists, I’ll take a shot or video. Thanks.

Overall, though, VERY impressed so far. TLP installed by default? That’s why my laptop battery performance has been so much better than 17.10 so far. Liking it…


#2

The black background is kind of random - several people have commented on this upstream

Needs someone to investigate - didnt see this before the 10.4 release so need to check what changes was done to the system tray between v10.3 and 10.4 of budgie-desktop


#3

Interesting background. Indeed, on reboot, it wasn’t there and all was fine. Of note, I was using Citrix on that prior boot and it too added some icons to the system tray that were similarly black backgrounded and floating. Again, all fine on reboot. I’ll continue to watch…


#4

I noticed TLP installed by default as well! Bravo! I was utilizing 18.04 but just recently installed the 17.10 release for schoolwork. Can’t beta test right now, a lot going on.


#5

I still have some floating icons on the system tray (mostly Citrix). Just FYI this is ongoing in 18.04. Thanks!


#6

Ack, wifi floating again tonight…

Screenshot%20from%202018-03-21%2021-44-16


#7

Please can you test a tentative fix - because this is so hard to reproduce its difficult to say if the change I’ve made helps or makes no difference.

sudo add-apt-repository ppa:ubuntubudgie-dev/unstable-test
sudo apt dist-upgrade

Reboot

thanks


#8

Sorry, no :man_shrugging:

Screenshot%20from%202018-03-22%2020-40-03

Let me know if you want me to test, because unlike the Wifi icon which is hard to reproduce, launching Citrix generates a system tray icon which floats every single time.


#9

On the other hand, Snaps are back with the unstable test update!


#10

I am more interested in the Wi-Fi icon going black and trying to determine when it happens. The floating icon thing is perhaps unique to Citrix and is probably a bug that needs to be reported upstream


#11

Noted, but just interesting to note Citrix doesn’t do that in 17.10. The black background and foreground floating process is the same for both…


#12

Hello, first time here! I’ve downloaded today’s daily of UbuBudgie 18.04, and tried it without installing from my live USB made on Etcher. There’s no wifi on my 2008 iMac at all, even having dug into the system preferences.

Nice selection of Backgrounds though. I’ll be back in a day or two to try again.


#13

@liari just realised - your issue is this upstream report:

Sorry about that - should have remembered that one and dug it out for you.


#14

No worries. So it’s a Budgie issue then… Thanks!


#15

notification_tray
Probably the same upstream issue but posting here anyways. I am on mobile data and the WiFi icon doesn’t go away. UB 18.04 daily build 20180410.


#16

@lungten I think this is a different issue - possibly specific to how network icon displays stuff on mobile data. If you move the panel from bottom to top and back to the bottom again via budgie settings does the network applet icon correct itself ?


#17

@fossfreedom Tried again today with 20180411 build. Moving the panel around and back/forth does not help.


#18

@lungten this means this is a new issue specifically about mobile data and how the icon is displayed on the panel.

I don’t have any experience in this area - it you be good to confirm how the icon is displayed on mobile data for xubuntu / regular ubuntu.

The issue needs to be reported upstream https://github.com/budgie-desktop/budgie-desktop


#19

note also @lungten - it is also worth checking another iconset such as humantity - does the icon displayed change? If so what does it look like?


#20

@fossfreedom Let me check with a different icon set and get back. On regular Ubuntu with GNOME (18.04) it is alright. The icon displays correctly both with the default icon pack and Papirus.