Budgie Arm64 (Raspberry Pi) VNC

I ticked the box for VNC but I have no idea which VNC it’s using. If it’s Tight or Real, neither work. I tried RDP, and also failed. Which one is it using?

Which version of Ubuntu Budgie are you using?

Also how are you enabling VNC? Are you doing it through Budgie Control Center or through the Budgie Pi configuration app?

The built-in VNC option in the Sharing section of Control Center does not work, however, the RDP option should. If you use the Remote options of the Pi Configuration app, you should be able to enable VNC there. It uses x11vnc to get the job done, but any viewer should work.

Just downloaded today - 23.04

I ticked the box in what I think said “Arm Configuration” or something. It had all the usual options you’d see in raspi-config.

So if you are using the Budgie Arm tweak tool, in theory it should work if you enable it through this app.


First time, clicking the button should install the vnc server, then you should simply be able to toggle it through this as well.


Likewise, you can use the terminal to enable / disable the Pi’s VNC server:

To setup:
/usr/lib/budgie-desktop/arm/scripts/budgie-vnc.sh setup <vncpassword>

Then to start or stop:
/usr/lib/budgie-desktop/arm/scripts/budgie-vnc.sh [enable|disable]

After this, you should have no issue connecting via VNC to the pi. I use Remmina currently, but it shouldn’t matter.

This option requires the user to be logged in before the VNC server will run. You can use the Auto Login option in the Arm Tweak Tool to work around this issue.

If you try to enable it through Budgie Control Center, you will see the option to use Legacy VNC. This does NOT work on Ubuntu Budgie. The Remote Desktop option should work fine though to provide RDP access. The downside to this option is it currently does not persist, so you have to toggle it every time you log in.

Thanks, your screenshots prompted me to unwind everything and go back to the basics. I didn’t remember seeing a second dialogue box after enabling it like your screenshot shows. Although I know I enabled VNC and SSH when I first booted into the desktop, when I brought it back to my desk and monitor it all shows as disabled. I enabled VNC again and got that popup this time and it all worked. Strangely enough, I can’t seem to get SSH to “show” as enabled even though it is and I am actively using it as I type this. It was fast when I had it at my desk, though it showed as unencrypted for some reason. Now its slow. I can leave that for another day though. Thanks for guiding me in the right direction.

Is your VNC very sluggish? I really don’t want to use RDP but I’m feeling cornered. Most of the time I can’t even connect to it.

You can see here the apparent “lag” relative to the cursor actions - through VNC. My first assumption was that something was eating up resources but you can see with top it’s not that.


top - 10:52:56 up 6 min,  2 users,  load average: 0.46, 0.75, 0.45
Tasks: 271 total,   3 running, 268 sleeping,   0 stopped,   0 zombie
%Cpu(s):  2.7 us,  5.4 sy,  0.0 ni, 91.9 id,  0.0 wa,  0.0 hi,  0.0 si,  0.0 st 
MiB Mem :   7634.3 total,   5844.8 free,    996.1 used,   1091.3 buff/cache     
MiB Swap:   1024.0 total,   1024.0 free,      0.0 used.   6638.3 avail Mem

Then I thought it was maybe to do with some kind of network issue so I check the speed and ping…

iperf3.exe -c pidev.local

Connecting to host pidev.local, port 5201
[  4] local fe80::5bae:8326:264d:5399 port 61359 connected to fe80::3491:8c24:ad21:cbc port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.01   sec  11.5 MBytes  95.4 Mbits/sec
[  4]   1.01-2.01   sec  11.1 MBytes  93.7 Mbits/sec
[  4]   2.01-3.00   sec  11.1 MBytes  93.6 Mbits/sec
[  4]   3.00-4.00   sec  11.1 MBytes  93.6 Mbits/sec
[  4]   4.00-5.01   sec  11.2 MBytes  93.5 Mbits/sec
[  4]   5.01-6.01   sec  11.1 MBytes  93.5 Mbits/sec
[  4]   6.01-7.01   sec  11.1 MBytes  93.6 Mbits/sec
[  4]   7.01-8.00   sec  11.1 MBytes  93.6 Mbits/sec
[  4]   8.00-9.00   sec  11.1 MBytes  93.6 Mbits/sec
[  4]   9.00-10.01  sec  11.2 MBytes  93.5 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.01  sec   112 MBytes  93.8 Mbits/sec                  sender
[  4]   0.00-10.01  sec   112 MBytes  93.8 Mbits/sec                  receiver

iperf Done.

ping pidev.local

Pinging pidev.local [fe80::ce72:e280:1b33:ee68%24] with 32 bytes of data:
Reply from fe80::ce72:e280:1b33:ee68%24: time=3ms
Reply from fe80::ce72:e280:1b33:ee68%24: time=5ms
Reply from fe80::ce72:e280:1b33:ee68%24: time=2ms
Reply from fe80::ce72:e280:1b33:ee68%24: time=1ms

I also tried the fkms driver instead of kms but that failed all together.

I haven’t had any luck. Im going to attempt to get realvnc-vnc-server up and running since I’ve never had a problem with it.

Honestly I am not sure why you are seeing so much lag with VNC. I have a couple of Pis that I use it with, and while it is never what I could call “positively snappy”, its quite usable. I have yet to see the amount of extreme lag you are getting. I am also curious as to why SSH was not showing as enabled and is running slow. (I even ran VNC over SSH and it was fine). I would be interested in hearing how RealVNC works out for you though.

Out of curiosity, which Pi model are you using?

Pi4B 8GB As much as I love using budgie I just can’t get VNC to run smooth :frowning:

I’ve recently tried to come back to this problem and I’m failing completely. I can’t even get VNC to work.

Also, I’ve switched back to 22.04 LTS with hopes that it would resolve all my problems. No luck.