Home Store Blog

VNC, tightvncserver, tigervnc and Budgie 18.04

#1

Hi.

Usually use on my sistems tightvncserver, but installed on my laptop, no work.

  • Admins config
  • Setup remote acces

Try unsetup, and install tightvncserver

  • Access with VNC Viewer, but only I see a grey screen

My xstratup file

#!/bin/sh

xrdb $HOME/.Xresources
# start budgie-desktop &
# Xsetroot -solid grey
## x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" & x-window-manager &
## Fix to make GNOME work
export XKL_XMODMAP_DISABLE=1
#/etc/X11/Xsession

I try severaloptions and not work.

Also I try uninstall and I try install tigervnc…

But not work because dependencies:

tigervnc-xorg-extension : Depende: xserver-xorg-core (>= 2:1.7.7)

Any ideas?

#2

Hi and welcome.

I am not familiar with tiger and tight VNC.

If I want to vnc to me UB desktop I search for sharing in the menu and set up the sharing screen option. I use a static password.

Then I use something like remmina to connect via the vnc protocol to the IP address of my UB machine.

#3

Thanks. But remmina is not Mac os X app…

#4

So you are using VNC from macos to view the UB desktop or the other way around?

If the former, if you set up screensharing as I said and then use your macos vncviewer what happens?

#5
  1. I like connect from Macos X (High Sierra) to Ubuntu Bionic with Budgie
  2. I use for too many connections, RDP (Remote Desktop) or VNC (Vnc Viewer). Also use Chrome for stupid connections…
  3. First try using Sharing of Ubuntu Budgie.
  4. Second I’ve tried install tightvncserver, and after tigervnc…

Well.

On step 3…

I’m checking and not see anything work for remote.

âžś  ~ ss -lnt
State         Recv-Q         Send-Q                  Local Address:Port                  Peer Address:Port
LISTEN        0              50                            0.0.0.0:139                        0.0.0.0:*
LISTEN        0              128                     127.0.0.53%lo:53                         0.0.0.0:*
LISTEN        0              128                           0.0.0.0:22                         0.0.0.0:*
LISTEN        0              5                           127.0.0.1:631                        0.0.0.0:*
LISTEN        0              50                            0.0.0.0:445                        0.0.0.0:*
LISTEN        0              50                               [::]:139                           [::]:*
LISTEN        0              128                              [::]:22                            [::]:*
LISTEN        0              5                               [::1]:631                           [::]:*
LISTEN        0              50                               [::]:445                           [::]:*

With this data, VNC not work… Normal. Not are any daemon form read connections…

With other problems with grey screen…

Best regards.

#6

What version of UB are you using? Have you done a full install or a minimal install?

#7

VErsion is in title. 18,04

Installed normal. Not minimal. Also instal vino and other utils for me.

#8

I’ve set my sharing options as shown - note that ss -lnt returns info indicating that the daemon is running. Please check that you have the switches enabled as shown - especially the top left switch in the dialog

#9

A lot of thanks. After I see your image,I understood that something strange was happening, so I restarted, and after the restart the demon was already shown in the listening, and the error messages in connection attempts were other.

I’m in the way, but I don’t get solution.

A lot of thanks.

#10

I think you have to disable encryption:

gsettings set org.gnome.Vino require-encryption false
1 Like
#11

Hi.

A lot of thanks…

With this settings work with VNC Viewer, TigerVNC…

Best regards. (Baraka Allah fik)