Budgie installer misses a step and gives "no root file system is defined"

Ok so I am trying to install Budgie 18.04.3 64bit on a new Dell inspiron 5000. My laptop currently only has one C drive and windows 10 installed on it.

I created a bootable usb drive using rufus (FAT32 and also tried with NTFS option) and tried to install it. Before launching the installer it gave me the ACPI error which I have mentioned in this post

So I ignored the error and continue with the installation. Got all the usual steps in the install wizard like set the language, keyboard etc. After selecting the Normal Install option the installer goes directly to this step skipping the one where you select “Alongside another OS” or “Erase and install Ubuntu”

If I click install now it gives me “no root file system defined” error

If I click on the “Change” or “+” buttons then the installer hangs and freezes

How do I fix this? A friend of mine has also installed Budgie on their Dell laptop but they never encountered this problem.

On my dell, when you have an nvme drive, I need to esure that AHCI is enabled and not raid.

  • Bios
    • Settings
      • System Configuration
        • Sata Operator

I have a slightly older XPS 13 (9350).

I’m not sure if your bios is the same, but worth a try.

1 Like

do I need to take anymore precautions before doing this?

a few more details:
my fast boot mode is thorough
boot mode is UEFI only with secure boot enabled in deployed mode.

my boot sequence is

Windows Boot Manager
UEFI Hard Drive

Oh, I’ve only ever used this with a single operating system. So I’ve made that change, then Blown Away the system installing a new operating system. I have secure boot disabled because I know at times it has problems with Linux. I use UEFI only. And I haven’t looked into the fastboot settings.

@palash25 fastboot should always be disabled otherwise no other operating system can be installed.

Ubuntu and its official flavours will be OK - it will install the necessary info to ensure booting works.

Oh, good to know! I’ll enable secure boot the next time I reload.