Budgie v20 assessment progress report

Hi Gents.
I am now trying Elementary OS v 5.1 (latest stable) and Budgie 20; yes I understand 20 is bleeding edge but as I use it hopefully I can contribute.
BTW I earlier made a preliminary video which Ive removed as someone complained, and I agree, it could be perceived as a review, and I am not qualified to review until using and comparing both Elementary and Budgie for a reasonable period.

First hours use Elementary install a couple of my important desktop utilities; copyq dropbox; problem 1 no icons in the tray. I know icons can be introduced by user, but it is additional work which should not be needed, and surprises me that Elementary is still limited in tray display in the latest version.
Over to Budgie in live I installed the above, both times the tray icons appeared; no issues there.
Go to Budgie install from live to HD: SDB is my SSD with the boot loader. Because I have several HDD attached to same machine, decided to overwrite Elementary backup on dev/sdc6, so marked that for install/format/ext4.
The installer there is a significant delay between screens in the installer, as it works out what to do next. Delay is a spinning cursor, but IMHO should have added info for user eg ‘Please wait, Im working out configurations…’ note - installation is a scary thing for many users, they need gentle prompts!
The below is what the installer decided had to be done; I went no further as the installer determined 2 x swap files; I have no idea why it would suggest two, as I made no other selections? Its unlikely formatting the swap areas is problematic, but I have to ask the question why?


There are three domains that comprise the UB world; the Ubuntu Ecosystem that include the installer, the package manager and the base OS, the Budgie desktop developed by Solus, and the UB developed items such as applets. Your critique of Budgie v20 seems to dwell on the installer.

The OP was a progress report. I had to move on and do something else to return later.

My question why should the installer choose to format an additional unselected SCSI1 possibly should be directed to Ubuntu forums.

Overnight I figured to go back same again, but this time select SCSI1 and check option [Do Not Use This Partition] (or similar), that may possibly sort the issue. However remains why the installer suggests to do this.
Regards, Al.

Ask on the ubuntu forums, unrelated to UB. Ubiquity installer comes from ubuntu

It is a very interesting observation.

Since 20.04 is in heavy development this observation would be better filled as a bug report since the devs will see that. Askubuntu and ubuntuforums are better for post release stuff where issues are not bugs.

So I would suggest you boot into the live session of the usb stick. Open a terminal and type

ubuntu-bug ubiquity

Complete the details behind your observation. Dont link this site since devs will not read it.

Thanks for that detail. I have suggested a bug report sticky in Post “Testing 20.04 - only for the most adventurous”
Thanks, Al.

No problems with raising here.

Personally I would prefer that so that we have visibility of upcoming stuff sooner rather than later.

Interesting day today. Swapped a screen out on phone my wife dropped twice. Amazing how the tiny plugs and board interfaces snap together. Chinese Redmi Note 5 quite a nice phone. The best part she basically has a new phone now :slight_smile:

I received my new Lenovo E590 I5 laptop, so was determined to install Budgie Ver 20.
The following comments apply and I will do appropriate bug report:
1…Laptop would not boot any USB image which turned out to be BIOS setting>>Restart>>Optimize Defaults=off (sort of fast boot/security to avoid other OS etc) (Laptop problem of course).
2…Boot off USB>>Budgie/Install/Defaults=‘computer has no default OS’

3…OK no OS, Windoze must have encrypted the HD which it had, and those settings disabled from Windows 10 then another reboot same thing, but if I use Budgie file manager the partition is visible:

But gparted cant work with a mounted partition. So doing a search found this:

Which didnt make an iota of difference.

This is serious stuff. I would assume Win 10 partition is encrypted by default now, and a user will try to install but since the installer doesnt know about Win 10, it kills the partition to install Linux.
Unless Im wrong, some serious damage control needs to be done in the Ubuntu installer.

Id also like on the installer final prompt showing effected drives before commit, the device the boot loader is to be located on. This is missing, but if I saw the system had decided my boot loader was on a USB external drive I would be alerted things were not right.

I used the following url a suggestions, but a new user could really get out of their depth.
Step 1 was to go to windows and shrink the windows volume.
Then I booted into budgie and used ‘something else’ defining ext4 size and swap partitions in current SSD.
Its not looking good so far the Install has hung on Configuring Apt… its been on that for 10 minutes with no progress so im going to stop as there is some permissions problems I think. Since the progress has not completed I dont expect any changes to boot/grub.
Later: I was correct; Windoze booted OK with correct sizes.
Installing Linux should not be this difficult IMHO.
I fully understand that the installer is not Budgie dev team, but are there any other install alternatives which behave in a more protective manner?
I tried Elementary 5 and it offered overwrite the Ubuntu partition.
Then rebooted selected Budgie, did full install, but still the boot did not instantiate Budgie.
Ive now rebooted a 3rd time, in effort to install budgie.
Every process is the same, but always end up with windows boot. This is inconsistency.

This does sound like the manufacturer has installed Windows in a weird and locked down way. There are a lot of workarounds in Ubiquity (the installer Ubuntu uses) but manufacturers find new ways to screw up our lives - especially if you are trying to dual boot.

Often the erase disk is the easiest way - but even here some manufacturers screw up the EFI boot process making life hard. i.e. they don’t follow the MS spec and lock down the process.

Blame the manufacturer - not any linux distro. That’s why there are dedicated linux resellers out there.

I’m sure there are workarounds available - linux folk are always can-do people - in this case you’ve got a hard-nut which I would personally would return and move to someone better.

ubuntuforums.org I find are often the best place for install issues and hopefully can guide you on how to unbreak the lockdown the manufacturer has put in-place.

It should not be that hard to be sure. However, as you say, Ubuntu forums would help. I shouldnt need help with my experience. What has transpired is budgie has been installed to the correct partition by the aforementioned methods; by not instantiating budgie I assumed my correct methods had not completed the installation which is partially right; outstanding was grub which seems to be where the installers last step hasnt been completed (thats if Im right in assuming grub is the last step). Ive looked at UEFI and the grub hasnt been created.
Later…found this comment: You should never boot in CSM/Legacy/BIOS mode if Windows is UEFI boot.
So created a new GPT/UEFI boot using Rufus under Windows. Booted and picked option ‘erase existing ubuntu 19.10’ (note the version needs changing in image file). For some reason UEFI is so slow, but in the end it worked, creating grub ubuntu/windows nice!

Problems in V20:

  • After install favourite COPYQ cant define tray popup as [super][c] or [super] anything. I suspect the key i/o is interrupting [super] due to [super] being the hotkey for applications search. This should not be so; [Super][space] or anything else for applications search should be defined in keyboard, but not define single key of [super].
  • Budgie Desktop settings/top panel size with this laptop are 30 minimum, otherwise the title bar of window maximized gets eaten by the tray bar for some odd reason. You would think smaller better but its the converse.
  • Hot corners (applet) - yes! this to me is one of my pet annoyances - they should be able to easily be defined as minimize current window, maximize current window; but this function needs to be a custom item - how to do the custom item?
  • Nemo - where do we go to set up addons or plugins? where are Nemo settings?
  • While on that; suggestion that dev popup tool for search items within the OS say I find a function thats not within the search can then contribute as time goes on you will build a robust help/finder.
  • Startup folder - we should be able to drag and drop appimage same as apps, I suspect you cant drop snaps either?
  • With Appimage and Snap they should easily be able to be added to applications and also be able to easily define custom icon. You have an Applications Settings which does not appear to do anything?
  • Minor detail but my personal favourite screenshot Shutter is not compatible ppa.
  • Software Installer often hangs in search eg type ‘video’ and nothing displayed with wait cursor. I have to enter a password for every application I wish to install.
  • After sorting the hotcorners how to I remove minimize and maximize on windows?

More to follow…please advise if fixes are made or any suggestions to correct me if Im wrong.

Super is a specific budgie only key - so not alot we can do here. Upstream issue.

EDIT: Think still worth investigating if anything else in GNOME gsettings has grabbed those specific shortcuts

Have a look here: Fix for Budgie Panel Overlap?

Should be a separate post

Should be a separate post

Should be a separate post

What’s the startup folder?

That’s a appimage/snap issue - they containerise their icons. No desktop should workaround container issues since workarounds break continuously

Don’t understand - what applications settings?

Not surprised - PPA’s are maintained by individuals and groups - so its not surprising this early a specific PPA is or isn’t available.

Ah - real issue - this needs reporting to launchpad: ubuntu-bug gnome-software

Should be a separate post

As an aside…
One of the great things about projects like Ubuntu Budgie is the participation of the community in the project. That is both in discussion on new or existing features, as well as contributing to the project, either by code or translations, or any other way you can think of.

If, in the discussion and feedback, it turns out many people would like to see feature A or B, or would like to see anything else changed, no doubt the team will seriously consider looking into it if it is within our reach, or will seriously consider to merge a PR. Many, many of the features and applets Ubuntu Budgie currently has, were the result of such discussion and interaction with our community, and it is an ongoing process.

What we are not open to however is a personal wish list, a summation of things you think are subject to change, to what you personally like or think how it should be. Most -if not all- items you mention are either unclear or a matter of taste, with a high “I find” degree, a clear and objective “why” is often missing.

I’d suggest if you really find something could be improved, make sure your arguments are solid and start a discussion, one subject at a time please. See if the community and we are convinced of your arguments.
An “assessment” like this, a personal wish list is not very useful however.

No problem, I wont bother you any more.
Topic closed