Can´t drag and drop

Hello, I can’t drag and drop. In windows, I usually just drag and drop files (docs, pdf, pictures) to emails to share the files as attachments. I also do this in wassap; I just drag and drop files to share.

Now, I am new to Linux and budgie, and can’t do this. In wassap (browser version), nothing happens at all. In gmail, is the same. I have tried other browsers, Firefox, Brave, Chrome and other applications Gmail, Outlook and wassap. It doesn´t work in Google Drive either. Drag and drop files is not possible.

I have to attach the files by clicking “add” or “attach” in the corresponding application, browsing the directory and then clicking the file. This is very frustrating and cumbersome.

Please keep in mind that at best I am a “newbie”. I am new to Linux, and even simple things are very hard for me. So I would appreciate a step-by-step solution “idiot proof” if possible. I know it’s too much to ask, but I would appreciate the help.

Maybe this info helps:
OS: Ubuntu Budgie 22.04.3 LTS x86_64
Host: 81YM IdeaPad 5 14ARE05
Kernel: 6.2.0-37-generic
Uptime: 23 mins
Packages: 1923 (dpkg), 27 (flatpak), 13 (snap)
Shell: bash 5.1.16
Resolution: 3072x1728
DE: Budgie 10.6.1
WM: Mutter(Budgie)

I have no idea why you cannot drag and drop.

For me, using firefox - I can compose a new message. Then from the file manager I can drag and drop onto the draft message.

Note - I use a touchpad.

If you open a terminal (tilix) and copy and paste the following what is the value returned in the terminal?

gsettings get org.gnome.desktop.peripherals.touchpad tap-and-drag

Thanks for the help.
-After pasting the command you suggested, the returned value is: “true”
-I use a mouse, but also tried with the touchpad and I still have the same problem. However, the right click has never worked either with my touchpad. I don’t know if that has anything to do with it.
-I have tried dragging different type of files like PDF, pictures, docs…I have the same problem with everything. I tried dragging from the desktop and from the file manager. The result is the same, it doesn’t work.
-At first, I thought I might have inadvertently changed some settings. But even though I have done so over time, the problem was there from the beginning. It never worked after I installed UbuntuBudgie for the first time. I have tried doing the usual after reading comments: updating, making sure everything is up-to-date.
-As I stated before, with other browsers I face the same problem.
Just to make it clear, I still keep having the same problem.
If you need any more information, let me know. Again, thx.

Are you running ubuntu budgie on a physical install on a laptop or are you using ubuntu budgie via a virtual machine install such as virtualbox?

I don’t even know what a virtual machine is. I followed instructions on how to install it directly in my laptop. I don’t dual boot, but left win10, just in case. I never use windows anymore, I just log in directly in Ubuntu budgie.

There is something I forgot to mention. I have tried to use flathub (flatpkas?) whenever I can. I also tried to change the default Firefox (snap?) to the flatpak version, as well as the other browsers. And I just found this old tutorial:
I have not tried to follow the instructions here because I really don’t understand them and don’t want to risk messing something. But maybe it is related? I don’t have permissions to drag and drop because they are flatpaks or something similar?

ah - yes. Flatpaks need to be given extra permission to use files from outside its immediate sandbox.

'fraid I’m not a flatpak user so can’t help specifically what extra instructions you need.

What I can say is the the default firefox in ubuntu works fine for me. I’ve never tried the flatpak version.

This answer looks like the sort of stuff you need to-do though.

Hope it helps

These permissions things are too advanced for me and I don’t want to mess anything, so I think I will just have to tolerate this. But thanks for the help.

Quick google reveals that there is a graphical flatpak called flatseal. Try that.

Thank you, I will check it out.