Home Store Blog

19.04 Ubuntu Budgie Beta release!

#1

The Ubuntu Budgie team are proud to announce our Beta release of Disco Dingo :slight_smile:

Any queries / issues please let us know on this thread and we’ll try to guide you where best to raise the problem.

Quick video showing the highlights:

3 Likes
Help test & fix 19.04 Ubuntu Budgie
#2

Hello, it is not possible for me to share my computer.
If I go to settings, sharing and then put the slider on, when I leave sharing and go back, the slider went back to off. This is so from the beginning, but I was thinking that this would be solved, but it is still not working.

#3

Hi @Tukkie and welcome.

Sharing is working here:

Note in the above picture the options I chose - to use a password - switched on the network as well.

Picture shows me connecting to a virtual 19.04 from my 18.04 host. The virtual is configured to use a bridged connection

#4

Hi, I did a minimal install, I don’t see screen sharing at sharing settings.
On another computer, I installed Budgie normally, and now I see screen sharing and if I switch that on, now the slider remains on. So there should be something extra to be installed if you do a minimum install.
I do not know, what to install extra, but I’m trying to find out.
So far, thank you for your support.

#5

There is a list of needed tests somewhere? I installed yesterday on my notebook, till now nothing to report.

#6

Really just use it as normal as you can. Obviously we are interested in looking at the changes listed in the release notes. But equally making sure all existing capabilities work as you would expect. Cheers.

#7

you need the vino package for screen sharing.

#8

Thanks, I reinstalled Budgie the normal way, but I cannot share a folder. Before on Nautilus I could right click and share the folder, but now on right click there is no possibility to share the folder?

#9

There is a plugin called Nemo-share that I think will do this. Will need to check it out … and if it works will look to make it available via backports for 19.04 … and longer term directly from the repos in 19.10/20.04 timescales.

#10

okey-dokey

I have added a nemo-share package to our backports PPA.

sudo add-apt-repository ppa:ubuntubudgie/backports
sudo apt upgrade
sudo apt install nemo-share

Reboot - there will now be a “sharing option” on right click of a folder.

#11

Hi, Thanks a lot, it works. regards.

#12

Hello, another thing that doesn’t work.
Menu editor doesn’t work. To descibe good, I changed language to English Unuted States.
Then I start menu editor again, and surprising, it works well.
So my language is Dutch. If I start in Dutch, and I select menu editor, you see for a while the icon in plank, but then the icon disappears and menu editor did not start.

#13

If you type menulibre into a terminal are there any errors reported ?

#14

If I run menulibre in terminal, I get following text:

(menulibre:31389): dbind-WARNING **: 12:35:59.114: Couldn’t register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(menulibre:31389): Gtk-WARNING **: 12:35:59.225: gtk_menu_attach_to_widget(): menu already attached to GtkMenuButton

(menulibre:31389): Gtk-WARNING **: 12:35:59.285: gtk_menu_attach_to_widget(): menu already attached to GtkMenuButton
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/menulibre/MenulibreApplication.py”, line 2217, in do_activate
self.win = MenulibreWindow(self, headerbar)
File “/usr/lib/python3/dist-packages/menulibre/MenulibreApplication.py”, line 250, in init
self.configure_application_treeview(builder)
File “/usr/lib/python3/dist-packages/menulibre/MenulibreApplication.py”, line 589, in configure_application_treeview
self.treeview = MenulibreTreeview.Treeview(self, builder)
File “/usr/lib/python3/dist-packages/menulibre/MenulibreTreeview.py”, line 48, in init
self._configure_treeview(builder)
File “/usr/lib/python3/dist-packages/menulibre/MenulibreTreeview.py”, line 59, in _configure_treeview
treestore = MenuEditor.get_treestore()
File “/usr/lib/python3/dist-packages/menulibre/MenuEditor.py”, line 123, in get_treestore
return menu_to_treestore(treestore, None, menu)
File “/usr/lib/python3/dist-packages/menulibre/MenuEditor.py”, line 111, in menu_to_treestore
treestore = menu_to_treestore(treestore, treeiter, item[3])
File “/usr/lib/python3/dist-packages/menulibre/MenuEditor.py”, line 100, in menu_to_treestore
tooltip = escapeText(item[2][‘comment’])
File “/usr/lib/python3/dist-packages/menulibre/util.py”, line 99, in escapeText
return GLib.markup_escape_text(text, len(text))
File “/usr/lib/python3/dist-packages/gi/overrides/GLib.py”, line 418, in markup_escape_text
return GLib.markup_escape_text(text, length)
UnicodeDecodeError: ‘utf-8’ codec can’t decode bytes in position 27-28: unexpected end of data

#15

Thanks - that confirms that there is a python issue when dealing with non-english languages.

Please can you report this to launchpad to let the menulibre developer know:

ubuntu-bug menulibre

This will open a web-browser - login with your launchpad ID.

Then in the detail section copy & paste the above + say that this occurs with the Dutch language.

cheers.

#16

I’m trying for about an hour how to report this to launchpad. I get a lot of pages how to, but I do not understand. I get an apport report that i can sent, but then I see a message that this is already reported. When i then look, I see a lot of reports from years ago, but then I do not know how to go further.

#17

Ah - the “apport report” is good news - it has recognised your issue.

I’ve scanned the list for you - indeed this is your report which has just been reported by Fedora.

https://bugs.launchpad.net/menulibre/+bug/1817885

So you’ve done everything right. Well done! You can now subscribe to that bug report to get further updates.

#18

Hello, it was not mine bug report, but that’s okay

The solution they gave works for me, with some differences.

sudo gedit /usr/lib/python3/dist-packages/menulibre/util.py


Search: return GLib.markup_escape_text(text, len(text))
Replace and save: return GLib.markup_escape_text(text)

closed #20