Cannot install Docker on Ubuntu Budgie 19.10

Docker cannot be installed on Budgie 19.10:

I followed the exact steps as outlined by ThaJeztah here:

See my post here: https://github.com/docker/docker.github.io/issues/8891#issuecomment-568225697

Even if I pick a specific Disco version, it does not work, same issue (I tried):

Setting up docker-ce-cli (5:19.03.3~3-0~ubuntu-disco) ...
Setting up docker-ce (5:19.03.3~3-0~ubuntu-disco) ...
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xe" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2019-12-22 02:42:21 CET; 3ms ago
     Docs: https://docs.docker.com
  Process: 5172 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
 Main PID: 5172 (code=exited, status=1/FAILURE)
dpkg: error processing package docker-ce (--configure):
 installed docker-ce package post-installation script subprocess returned error exit status 1
Processing triggers for man-db (2.8.7-3) ...
Processing triggers for systemd (242-7ubuntu3.2) ...
Errors were encountered while processing:
 docker-ce
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I install Docker? Or does Budgie not support Docker at all?

I haven’t got a 19.10 physical host to try with. However I do use docker successfully on a 18.04 UB physical host.

So I am guessing its your specific setup that is failing

I wouldn’t say that Ubuntu Budgie does not support docker. The reason being is it is still just Ubuntu with a desktop bolted on. I’m running docker via the snap package. This might be an interim solution for you until the larger problem is solved. I have a 1910 installation around that maybe I can try this out tomorrow and see if I run into this. I just happen to be out and about today.

1 Like

Well, “my specific setup” is a clean install of UB with nothing else installed or configured on a simple Intel Core i3-9100 16gb ram home computer.

It’s a bit worrying you, a UB team member, can draw such a conclusion based on the fact an older version of Docker works on a 1.5 years older version of Budgie… clearly my point is it doesn’t work on 19.10 and your info doesn’t seem to add anything constructive to the topic.

You can’t find Docker for Eoan Ermine (Ubuntu 19.10) because it doesn’t exist. Docker may not make a repository for any but Long Term Support versions. Use the repository for Disco Dingo (19.04) or even an earlier LTS version. It’s the latest Docker and runs fine. Only the repository needs changing.

You asked very specifically that if this was a budgie issue. Clearly it is not.

I am pointing you towards where docker clearly does work. The fact that bionic is a given age or not is neither here not there. It is a well looked after package with multiple updates including security updates.

Since docker isnt a budgie specific issue I am going to redirect you towards better forums for this. askubuntu.com and ubuntuforums.org

Just to add to this and echo what @Twelve stated.

cat /etc/apt/sources.list.d/download_docker_com_linux_ubuntu.list                        ─╯
deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable

The above is on my 19.10 machine. And it works great.

The steps generally are:

  • Ensure docker.io and such are not installed (historically out of date - although Debian just updated finally)
  • Add their apt-key (on the docker site in their install instructions for Ubuntu)
  • Add the repo (changing the release version to what they support) - like above.
  • apt update
  • install docker-ce and docker-compose if you use it.

I am not sure if you use ansible or not, but here is a small “task” to get this done. (yes it should be built as a “role”, but I put this together quickly).

- name: Remove Old Docker APT Packages
  apt:
    name: "{{ rempackages }}"
    state: absent
  vars:
    rempackages:
      - docker
      - docker-engine
      - docker.io

- name: Add Docker's public PGP key to the APT keyring
  apt_key:
    id: "9DC858229FC7DD38854AE2D88D81803C0EBFCD88"
    url: "https://download.docker.com/linux/ubuntu/gpg"

- name: Configure Docker's upstream APT STABLE Repository for 19.10
  apt_repository:
    repo: "deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable"
    update_cache: true
  when: ansible_distribution == 'Ubuntu' and ansible_distribution_release == 'eoan'

- name: Configure Docker's upstream APT STABLE Repository when NOT 19.10
  apt_repository:
    repo: "deb [arch=amd64] https://download.docker.com/linux/ubuntu {{ ansible_distribution_release }} stable"
    update_cache: true
  when: ansible_distribution == 'Ubuntu' and ansible_distribution_release != 'eoan'

- name: Install Docker APT Packages
  apt:
    name: "{{ packages }}"
  vars:
    packages:
      - docker-ce
      - docker-compose

HTH

@zilexa Forgot to tag you. :point_up: