Cannot Pin application shortcuts on Panel

I tried to pin applications on Panel/Taskbar but its not working. It only works for some of the Applets only.

Hi and welcome

Please give an example application that you cannot pin. Where have you installed the application from?

Show a screenshot of the right click options you see when running the application … obviously we need to understand why you are not seeing the star pin option.

Can you confirm that the application you are trying to pin is visible in the menu.

Is it a snap application, flatpak, appimage?

Hi Foss,

  1. I i right click on any of the app in the ubuntu menu either its installed by default or any other package manager like snap and flatpak. its not showing any options.

Just for e.g I have installed brave browser from snap and after right clicking i am not getting any options

  1. Not able to get screenshot of the menu, but other things screenshot is working.

I have tried screenshot from the printscreen and alt + printscreen and other shortcuts.

OK, to pin you need to start the application. Look at the running application in the panel, right click and choose the star icon.

I am assuming here you have the icon task list applet on your panel.

Regarding screenshot :

when you need to « capture » the menu and some other kinds of windows ( popover, dialog box ) don’t use the keyboard shortcuts for screenshot, but prefer launching the screenshot app first and there, chose « screenshot after a delay of ×× seconds ».