Can't use whole screen on monitor which comes after plank

I have multiple monitors setup.
monitors

If I use Plank on monitor number 2 (position left) then the monitor number 4 is useless.
I can’t move any application to that monitor (only to the half).

This bug occurs in any other setup… If the Plank is on monitor number 3 then 2 and 4 don’t work well.
If it’s 2 and positon bottom then monitor number 1 doesn’t work etc.

Only combination that works is to always put a Plank on the most left monitor (in the above situation it is monitor number 4) but that’s totally impractical.

Any solution?

have a play with the auto hide options - if you run plank in dock mode then that will interfere.

I believe it is also possible to place plank on individual monitors - but I don’t know if you can configure each plank separately.

https://answers.launchpad.net/plank/+question/204593

1 Like

I am pretty sure this is related to this bug https://bugs.launchpad.net/plank/+bug/1755731. I ran into it while develloping window shuffler. Unfortunately, there was never any reaction on the report, nor fix. Please see if you can use the space without plank running to confirm.

1 Like

I can use space when Plank is turned off or set to auto-hide. Thanks!
This definitively improves the experience. I’ll have to get used to auto-hiding now.

Problem with hide-show in the first place is that there is no monitor edge so you have to slow down the mouse to show Plank (dock) or you’ll slip to the next monitor.

sounds like need a “sticky edge” type feature. Dunno if there is a GNOME mutter type feature available. Would need to dig around in the various dconf settings.