'Ctrl' key not being sent to games


I’ve tried the Ubuntu forums, Reddit and Steam forums with this one and haven’t had any luck, and there’s absolutely nothing like this on search engines so I think it might be a Budgie thing.

I’m enjoying using Budgie enough that I’m starting to migrate to it for gaming too. However, I’m having an issue where Ctrl isn’t being registered by games. On Steam I’ve tried FTL (native Linux client I believe), Cogmind (via Proton and via Wine).

I noticed Ctrl+Shift+U was bringing up a little unicode entry text box (instead of the sending it to the game), so I suspect the OS is still listening to Ctrl. I manage to disable that Ctrl+Shift+U behaviour by changing “Keyboard input method system” from IBus to XIM, but it still hasn’t solved the issue of Ctrl not being sent to games.

Note that Ctrl works fine in every other instance - for Ctrl+C/V kinda stuff, sending it to a remote machine through remote desktop, etc.

Can anyone help me debug this one and find out what’s going on?
Thanks a lot!!

Have you got a mouse/touchpad option in settings like this?

Woah no way, that was it!!

I found that setting in an app called “Tweaks”, and it was indeed turned on. I have absolutely no idea why that would be turned on by default. Even so, Ctrl wasn’t “showing the pointer” when pressed as the setting suggests, but it was indeed responsible swallowing the key press.

Everything works perfectly now, thanks for that.

Also dunno how I missed that post in my searching…

Not a regular app’ shipped by Ubuntu Budgie. Do ( or did ) you have many desktop environments installed ?

Might be tougher than expected to use many DE on one ×buntu installation and furthermore under one and only one same user.