Weird Keybinding bug :-(

Hi guys,
Budgie is superb and I use it as my daily rive since some time now and would not go back for anything else that I know of.
Still, there is a small bug I found in Keybindings I think…

Here’s the thing : I use a lot of workspaces and I would like to navigate through them with keybindings.
Doing so is (as far as I have found) a little awkward as you need to install dconf Editor first, and then find the place to configure the keybindings (org=>gnome=desktop=>wm=>keybindings).

I was able to configure to my likings except for one move : “Right” is NOT WORKING whatever shortcut I would like to assign to it :frowning: I’ve tried several settings, no go… I’ve check where I could if that is assigned to another action, found none :frowning:

Anyone else getting this ?


That’s odd. Not only should ctrl + alt + left/right work out of the box, but also dynamic workspaces. Please remove the shortcuts you set for this shortcut, remove the files in ~/.config/budgie-desktop and restart. This will reset our overrides.


Thanks a lot for your answer, but THAT IS NOT WHAT I WOULD LIKE TO DO…
It works, I know…
But I don’t want to have to press half a dozen keys to achieve a basinc operation that i’ll do like 30 times a day :frowning:

I would like :

  • Control UP to switch workspaces from 10 to 1 ;
  • Control Down to switch workspaces from 1 to 10 ;
  • Control left to move the currently selected window to the upper workspace ;
  • Control Right to move the currently selcted window to the lower workspace…

I can achieve the first 3 ones by chnaging the default config… No problem.
But the latest : NO GO…
And whatever action I assign to Control-Right => not working :frowning:
So I took Shift-Control-Right…


I have a similar issue! Every now and then, all my custom key bindings will stop working. Even the bindings that came out of the box such as ‘F12’ for tilix --quake
Sometimes resetting keyboard shortcuts under keyboard settings helps as the custom bindings are not removed or logging out and back in. ctrl + alt + left/right is also inconsistent.

Yours sounds very different to this topic. Have a look here and see if the ibus trick works for you