Ubuntu Budgie 19.10 Shortcut Menu

I am unable to add to or modify the keyboard shortcut menu (Settings->Devices->Keyboard).
The problem appears Budgie related, since in Ubuntu 19.10, the keyboard shortcut menu works perfectly well.

I have tested the latest daily and updated fully. All is working fine.

I am still unable to add or modify keyboard shortcuts. I have to assume therefore that this is a hardware problem.

I will therefore have to switch to Ubuntu 19.10. As I long time supporter (silver member) I wish the project well for the future.

Can you please boot into a live-session via the latest daily. Can you add or modify keyboard shortcuts there?

I tried the latest daily (8/10/2019) live session. Unfortunately I still can’t add or modify keyboard shortcuts. A couple of the built-in keyboard shortcuts work, but the majority don’t.

hmm - that’s very interesting.

I’m also aware the GNOME 3.34.1 stack updates are being packaged up as we speak and are being released over the next day or so. Hopefully this will have the fixes resolving your issue (:crossed_fingers:)

No clue if it is of any help, but what shortcuts do work, and what shortcuts (examples) don’t? Is it always the same ones that do/don’t work?

The following keys work:-
Launch terminal
Save screenshot to terminal
Hide window
Maximise window
View on split left
View on split right

They only work if you don’t change the shortcut key. It’s always the same keys which work.
there may be other shortcut keys which work, I haven’t tried every shortcut key.

Does this suggestion help? Volume up-down, calculator, ctr-ALTl T, windows key +A and more, not working anymore

I tried the suggestion to open settings -> region&language and there, click on “manage installed languages” then changed “keyboard input method system” to none instead of ibus, more in hope than expectation. I rebooted Ubuntu Gnome, and all the shortcuts are working!

Many thanks to you, fossfreedom, I thought I was going to have to give up my favourite distro.

Many thanks for the step-by-step. Should be very useful if anyone has this issue.


Just to add to this. I set my IBUS to “none”, and then rebooted… shortcuts are still not working. (19.10). Then ran updates, and rebooted a second time. All came back.

I am still haunted by this issue. Shortcuts seems to work sometimes, but lately the they have stopped working altogether. It’s really frustrating. Hope it will get addressed once & for all soon.

What version of UB are you using? If 18.04 have you got our backports PPA enabled?

19.10, with PPA http://ppa.launchpad.net/ubuntubudgie/backports/ubuntu

K. I can confirm this is resolved in 20.04. The fix isnt in the 19.10 backports.

1 Like


I am getting copies of emails to and from someone with the login name “cbm”. I am not sure why I am being sent these emails, since my login name is not “cbm” I would appreciate it if you could make sure that I don’t get any more.


Colin Mills

@cojom I think its because @cbm has replied to your topic - so you are receiving emails on the topic still.

You can click the “bell” icon (vertical slidebar) to control what level of replies you want to be notified on - or even to stop watching completely.