Error when install Ubuntu on laptop Dell 15 5558

Uploading: DSC_0213.JPG…

Help me, pls. I dont know what happen with my laptop when i install Ubuntu.

Please reupload the image since it hasn’t appeared in your post.

I have installed ubuntu before, but when I reboot, I get the same error. I have reinstalled it but it still error.
Pls help me. I am text by ubuntu with usb.

this is my ssd, where i install ubuntu.

Please have a good read of the following - it really depends on what options you chose when installing.

For example if you have multiple drives - did you install ubuntu on a secondary drive and also installed the boot part on the secondary drive - is should have been the primary.

There could be other issues as well - the topic I’ve linked to below explains the common issues.

Obviously the windows referrals in the topic means you need to apply your image backup which I’m sure you did before installing.

Is it possible that the hard drive lost the boot file?

Because i only have two hard drives, one ssd and hdd and i install on ssd. Boot order is also in order: first is s


sd hard drive.

I think that you might have to rebuild from scratch. Before we go further, I would like to clarify a few questions:

(1) At this point, you have installed Ubuntu but your Dell Inspiron 15-5558 will not boot because a bootable drive is not recognized.

(2) I understand that your Inspiron15-5558 has two drives – an SSD and a HHD. However, that does not seem to be consistent with either the 15-5558 Specifications or the 15-5000-series Service Manual, so I would like to make sure that I understand. Could boot into BIOS and look for System Configuration > Drives and let us know what is reported? One drive or two drives, and what types (SSD or HHD) for each?

(3) If I understand correctly, you are trying to install Ubuntu using a USB. When you boot to the USB (USB Storage Device in your BIOS) the Ubuntu Live session boots from the USB. Is that correct?

(4) I see from the BIOS screen you posted that your “Boot List Option” is set to “Legacy” rather than UEFI. Looking at the troubleshooting guide posted by @fossfreedom, one of the recommended solutions is to switch from Legacy boot to UEFI Boot with Secure Boot enabled. That is the modern Ubuntu standard, as far as I know.

(5) When you installed Ubuntu, did you select the “erase everything and install” option or did you use one of the other options (“install alongside” or “custom”). In your case, “erase everything and install” is probably the best solution at this point. That option will clean the target drive and repartition the drive as part of the installation process. If you have UEFI (rather than Legacy) enabled at that point, the process will install an EFI boot partition, which is preferred for Ubuntu.

I apologize for asking these basic questions, but I don’t yet understand the situation, and I would like to understand it so that I can offer some help.

My thinking at the point: Assuming that you can boot into a Live session, it might be that your best option at this point is to switch from “Legacy” to “UEFI”, enable Secure Boot, and reinstall Ubuntu with EFI rather than a Legacy install.

First, I want to say thank you very much.

Next, my computer at first only had one hard drive, a HDD, later I upgraded to an SSD and inserted the HDD into the CD drive with Candy Bay.

When I run the standard UEFI, my device shows up like the video below, because normally I run in Legacy.

The Ubuntu lite version still boots normally.

Let me see if I understand this.

You have an SSD located in the 2.5" slot connected to your motherboard. You installed Ubuntu Budgie on the SSD but on boot the drive is not recognized as a bootable disk.

You have an HHD installed in a caddy adapter fitted into your CD-ROM drive/slot. “Ubuntu lite” (Lubuntu?) is installed on the HHD in the caddy, and the drive boots and runs “Ubuntu lite” normally.

That doesn’t sound right. What have I got wrong?

Ubuntu lite is in USB, and HDD is not installed at all.

For the rest, everything you say is correct.

Okay. So this is what I understand:

(1) The Ubuntu Budgie installer is on the USB.
(2) The USB boots, opens a Live session of Ubuntu Budgie and will install Ubuntu Budgie on the SSD.
(3) The SSD is in the laptop. You installed Ubuntu Budgie on the SSD. The SSD does not boot. The error reported is “Invalid partition table!”
(4) The HHD is not in the computer at all.
(5) You want to install Ubuntu Budgie on the SSD and you want the SSD to boot into Ubuntu Budgie.
(6) You want to have Ubuntu Budgie as the only operating system on the computer.

I am not 100% sure why you are getting the “Invalid partition table!” error. Several things could be causing the error. The most likely reasons are (a) the boot partition was not properly set up, or (b) the MBR partition table is corrupted.

I think that your best option at this point is to rebuild the SSD from the ground up, starting with setting BIOS to modern UEFI standards and installing a “clean” (that is “wipe the entire drive and install Ubuntu Budgie as your only operating system”) installation pf Ubuntu Budgie on the computer.

I will be happy to work through each step with you if that is what you want to do.

so how do i reinstall like new? Namely the brand new UEFI to install Ubuntu??

I suggest the following**:

(1) BIOS – Go into BIOS (F2 clicks during boot to get to BIOS menu). Check the following settings:
(a) Boot Sequence – set “Boot List Option” to “UEFI” rather than “Legacy”.
(b) System Configuration > SATA Operation – set to “AHCI” rather than “RAID”
(c) Secure Boot > Secure Boot Enable – Set to “Enabled” ***

(2) BIOS – Save settings and exit.

(3) BIOS – Boot into BIOS again and check to see that the settings saved. If so, go on to Step 4. If not, repeat Steps (1) and (2) as needed.

(4) TEST Installation USB – Boot into the Installation USB (F12 clicks during boot to get to Boot Menu) and open a Live session. Click “Try Ubuntu” and to make sure that Ubuntu Budgie runs and that wifi works. Shut down the computer.

(5) INSTALL Ubuntu Budgie:
(a) Boot into the Installation USB (F12 clicks during boot to get to the Boot Menu).
(b) Click “Install Ubuntu” to begin the installation process.
(c) When you get to the “Updates and Other Software” screen, select “Normal Installation” and click on both “Download updates while installing …” and “Install third-party software for graphics and wifi hardware …” The “Install third-party …” click should install drivers for your NVIDA graphics card.
(d) When you get to the “Installation Type” screen, select “Erase disk and install …” This is the most important step in the process because it will wipe the disk, install new partitions and set a working EFI partition.
(e) Finish up the installation.
(f) At the end of the installation process, you will be prompted to remove the Installation USB and restart the computer. Make sure that you remove the USB when prompted.

At this point, the computer should boot into Ubuntu Budgie.

Please take notes on everything you do just in case something goes wrong and we have to troublehsoot.

=============

** I am using the BIOS from a 2016 Dell Optiplex for reference. The BIOS screens are similar to yours, but might not be identical, so you might have to look a bit to find the setting.
*** If you later find that the HHD in your caddy is not recognized, that probably means that the caddy is not Secure Boot registered. In that case, you can disable Secure Boot later. If the caddy is from a reputable manufacturer, it should be Secure Boot registered.

2 Likes

I did!!!

First I used the Hiren boot installer to reinstall MRT to my hard drive. then I go into the Ubuntu installer and install Ubuntu with the “Parallel install with Ubuntu version I have installed” mode.

Finally my Ubuntu recognized the SSD. Then I followed your way to tweak the Bios.

Tks youuu.

1 Like

I’m glad it worked. Enjoy Budgie. It is a great desktop environment.

1 Like