Home Store Blog Development

Ubuntu freezes during installation


#1

Hello,
I’ve been trying to install Ubuntu Budgie 18.04 (downloaded from the official site), but the installation freezes whenever i reach the place where i have to do Disk Partition, and sometimes i can’t even make it to the installation screen. None of the partitions i have appear on the screen and it freezes when i press any of the options (create a new partions, delete …)
Ubuntu runs perfectly in Live Mode and on my Virtual Machine.
I’m using MSI GF-63 8rd with Windows 10 already installed, 8GB RAM, 1TB HDD with 16GB Intel Optane Memory (Rapid Storage Technology). Bios mode is already in UEFI (the other 2 options are Legacy and UEFI with CSM), and I’ve already disabled Secure Boot and Fast Boot.


#2

You have a nvidia card by the looks of it.

Do you also have an intel graphics chip? If you do then there should be a switch in your efi settings to default to intel graphics.

If you dont what you can do is boot with nomodeset. Once installed, boot again with nomodeset until you reach the desktop. At that point you can install the nvidia drivers offered to you. All should be ok at the point.

This is all explained here

Note. With dual booting windows and installing nvidia drivers you may also have to disable secure boot in your efi settings


#3

The problem is, I get stuck at the Hard Disk Partition. None of the partitions display and if i press any button, it stops responding.
Now, after trying your solution, it doesn’t freeze anymore but instead it just quits the installation


#4

this issue? https://askubuntu.com/questions/486556/no-partitions-found-while-installing-dual-boot-win8-ubuntu-14-04


#5

I disabled the Intel Optane Memory (RST) alongside with nomodeset and my problem’s fixed now.


#6

My problem now is intel rapid storage technology RST. I had to switch to AHCI so that ubuntu can detect the hard drive volumes… Is there anyway i can use RST with ubuntu? I’ve deleted windows and installed ubuntu on my HDD, so intel optane memory is useless now…
Also, after trying nomodeset, the resolution’s terrible now and I’ve tried to use terminal to get the graphics drivers, didn’t work


#7


#8

For the drivers run

software-properties-gtk

Click on the additional drivers tab and install the nvidia driver that is offered to you. Then you dont need to use nomodeset

From a quick look around it looks like Intel themselves have not pushed the drivers for RST into the linux kernel - or if they have its probably in a staging branch waiting to be pulled into the kernel by Linus. The ball is in Intel’s court here - it is their technology.

EDIT: My bad - not a kernel issue https://www.intel.com/content/dam/www/public/us/en/documents/white-papers/rst-linux-paper.pdf

Seems to be you have to use a software RAID type configuration - but I know nothing of that.