18.04 install hangs


Fairly new to Linux and ran Ubuntu for the past 2 months. Wanted to move to Budgie. I did a full wipe off my HDD and booted from USB. It gets halfway through the install to the screen where it speaks about Libre Office, but then it completely freezes and I can’t do anything expect reboot and try again.

I’ve tried 2 different USBs both used to install Ubuntu 18.04 just fine.

Any help or direction would be appreciated.

Hi Jivy26, have you checked MD5 has of the iso you downloaded to see if it corresponds to the one from the website?

1 Like

Yes even redownload and reflashed USB. Trying torrent download option and going to flash that and see.

Have you tried to set nomodeset and boot with it? You can do it by pressing F6 and ESC while booting and editing quiet splash — to nomodeset.

Flashing the torrented version now and will set that before I boot thank you.

Will report back rather good or bad news :grinning:

Great support btw!

So ran it without nomodeset just to see and it hangs on the Language selection.

Ran it with nomodeset and removed quiet splash and it crashed on load and sent me to the live cd. From there I see it is saying:

ubiquity crashed with SIGSEGV in__Gl_getenv()

Currently posting this from the live cd.

Edit: Trying to install from the live cd.

What GPU are you using?

AMD Radeon T5.

Also install from Live CD went fine now. Boots to login screen and freezes, though I can still move the mouse. I just can’t interact with the login in a anyway.

Alt+f2 isn’t working. Normally used in Ubuntu to see what the hang was but can’t here

Can you go to TTY and then run update and see what happens? Also let’s see if the kernel updates will solve the problem.

So I got it to boot with nomodeset updated rebooted and if nomodeset isn’t set at boot it will freeze

Updated everything and kernel to 4.18.5 and all is well without nomodeset. Thank u

Thanks for the update. If you have any more questions, don’t hesitate to ask. :slight_smile:

Just curious, how did you do that ?